Bug 1573864 - Cinder update disables v1 API
Summary: Cinder update disables v1 API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z5
: 11.0 (Ocata)
Assignee: Eric Harney
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 11:52 UTC by Attila Fazekas
Modified: 2018-08-03 18:35 UTC (History)
8 users (show)

Fixed In Version: openstack-cinder-10.0.6-25.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-18 16:48:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1611 0 None None None 2018-05-18 16:50:10 UTC

Description Attila Fazekas 2018-05-02 11:52:41 UTC
Description of problem:
tempest.api.volume.admin.test_volume_quotas.BaseVolumeQuotasAdminTestJSON.test_quota_usage_after_volume_transfer started to fail in the recent builds.


Version-Release number of selected component (if applicable):
python-tempest-16.0.0-2.el7ost.noarch
python-tempestconf-1.1.3-1.1.el7ost.noarch
openstack-tempest-16.0.0-2.el7ost.noarch
openstack-cinder-10.0.6-24.el7ost.noarch
python-cinder-10.0.6-24.el7ost.noarch
python-cinderclient-1.11.0-1.el7ost.noarch



How reproducible:
always

Steps to Reproduce:
0. Install
1. ostestr -r tempest.api.volume.admin.test_volume_quotas.BaseVolumeQuotasAdminTestJSON.test_quota_usage_after_volume_transfer

Actual results:
tempest.api.volume.admin.test_volume_quotas.BaseVolumeQuotasAdminTestJSON.test_quota_usage_after_volume_transfer[id-8911036f-9d54-4720-80cc-a1c9796a8805]
---------------------------------------------------------------------------------------------------------------------------------------------------------

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/tempest/api/volume/admin/test_volume_quotas.py", line 156, in test_quota_usage_after_volume_transfer
        self.alt_client, volume['id'], 'available')
      File "/usr/lib/python2.7/site-packages/tempest/common/waiters.py", line 192, in wait_for_volume_resource_status
        resource_status = show_resource(resource_id)[resource_name]['status']
      File "/usr/lib/python2.7/site-packages/tempest/lib/services/volume/v1/volumes_client.py", line 56, in show_volume
        resp, body = self.get(url)
      File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 292, in get
        return self.request('GET', url, extra_headers, headers)
      File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 666, in request
        self._error_checker(resp, resp_body)
      File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 772, in _error_checker
        raise exceptions.NotFound(resp_body, resp=resp)
    tempest.lib.exceptions.NotFound: Object not found
    Details: {u'message': u'The resource could not be found.<br /><br />\n\n\n', u'code': u'404 Not Found', u'title': u'Not Found'}
    


Expected results:
{0} tempest.api.volume.admin.test_volume_quotas.BaseVolumeQuotasAdminTestJSON.test_quota_usage_after_volume_transfer [4.144642s] ... ok


Additional info:
It is possible the cinder responded on v1 before,
but according to its config it was not expected.


Changing the
   cls.alt_client = cls.os_alt.volumes_client
to
   cls.alt_client = cls.os_alt.volumes_v2_client 

helps to workaround the issue, but cls.os_alt.volumes_client expected to be a v2 client by default.

Comment 11 Attila Fazekas 2018-05-04 11:14:51 UTC
The test stopped failing, thank you.

Comment 12 Tzach Shefi 2018-05-07 12:41:23 UTC
Verified on:
openstack-cinder-10.0.6-25.el7ost.noarch

This tempest test passed automation run.

Comment 16 errata-xmlrpc 2018-05-18 16:48:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1611


Note You need to log in before you can comment on or make changes to this bug.