Bug 1573865 - [WebAdmin] Move disk dialog displays orange container for warning message even when it is empty
Summary: [WebAdmin] Move disk dialog displays orange container for warning message eve...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: shani
QA Contact: Shir Fishbain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 11:56 UTC by Yosi Ben Shimon
Modified: 2018-06-26 08:41 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:41:50 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
move disk dialog (270.30 KB, image/png)
2018-05-02 11:56 UTC, Yosi Ben Shimon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91261 0 master MERGED webadmin: Use alert instead of a label on DisksAllocationPopupView 2018-05-15 15:53:52 UTC
oVirt gerrit 91268 0 ovirt-engine-4.2 MERGED webadmin: Use alert instead of a label on DisksAllocationPopupView 2018-05-16 08:23:00 UTC

Description Yosi Ben Shimon 2018-05-02 11:56:45 UTC
Created attachment 1429965 [details]
move disk dialog

Description of problem:
When trying to move a disk, the "move Disk(s)" dialog displays an empty orange rectangle container for warning even if it's empty.
It happens on a thin allocation disk that resides on NFS or GlusterFS SD.

This container displays warning message like for example, when you try to move a disk and the source SD is in maintenance.
So the warning is: "The following disks cannot be moved: test_vm_Disk1, hover over a specific domain for more info"

Version-Release number of selected component (if applicable):
WebAdmin version: 4.2.3.3-0.1.el7

How reproducible:
always

Steps to Reproduce:
1. Click on "Disks" under "Storage" tab on the left menu.
2. Select a thin provisioned disk on NFS or GlusterFS SD
3. Click on the "Move" button

Actual results:
The "Move Disk(s)" dialog displays an empty orange container for warning

Expected results:
If there is no warning to display, just hide the container.

Additional info:
See attached screenshot

Comment 2 Yaniv Kaul 2018-05-14 15:57:55 UTC
Severity...?

Comment 3 Shir Fishbain 2018-05-27 15:16:52 UTC
The "Move Disk(s)" dialog displays in orange container for warning

Used:
4.2.4

Comment 4 Sandro Bonazzola 2018-06-26 08:41:50 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.