Bug 1573878 - When ceph is unreachable, Gnocchi raise an exception instead of the correct error message.
Summary: When ceph is unreachable, Gnocchi raise an exception instead of the correct e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cradox
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: z2
: 13.0 (Queens)
Assignee: Mehdi ABAAKOUK
QA Contact: nlevinki
URL:
Whiteboard:
: 1588406 (view as bug list)
Depends On:
Blocks: 1599826
TreeView+ depends on / blocked
 
Reported: 2018-05-02 12:24 UTC by Mehdi ABAAKOUK
Modified: 2018-09-12 04:55 UTC (History)
10 users (show)

Fixed In Version: python-cradox-2.1.0-1.el7ost
Doc Type: No Doc Update
Doc Text:
-
Clone Of:
: 1599826 (view as bug list)
Environment:
Last Closed: 2018-08-29 16:32:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 14112 None None None 2018-07-10 16:25:14 UTC
Red Hat Product Errata RHBA-2018:2573 None None None 2018-08-29 16:33:24 UTC

Description Mehdi ABAAKOUK 2018-05-02 12:24:20 UTC
Description of problem:

2018-05-02 12:12:17,642 [21] ERROR    gnocchi.utils: Unable to initialize storage driver
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tenacity/__init__.py", line 298, in call
    result = fn(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/__init__.py", line 117, in get_driver
    conf.storage, coord)
  File "/usr/lib/python2.7/site-packages/gnocchi/storage/ceph.py", line 48, in __init__
    self.rados, self.ioctx = ceph.create_rados_connection(conf)
  File "/usr/lib/python2.7/site-packages/gnocchi/common/ceph.py", line 70, in create_rados_connection
    except rados.InvalidArgumentError:
AttributeError: 'module' object has no attribute 'InvalidArgumentError'


We have two solutions to fix that:

* uninstall and remove python-cradox (python-rados will be used instead)
* update python-cradox to something >= 2.0.0

Comment 2 Mehdi ABAAKOUK 2018-06-07 12:59:30 UTC
*** Bug 1588406 has been marked as a duplicate of this bug. ***

Comment 14 Joanne O'Flynn 2018-08-13 11:18:39 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 16 errata-xmlrpc 2018-08-29 16:32:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2573


Note You need to log in before you can comment on or make changes to this bug.