Bug 1573893 - OSPD 12 Undercloud - Infrastructure Provider refresh failed
Summary: OSPD 12 Undercloud - Infrastructure Provider refresh failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.10.0
Assignee: Scott Seago
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks: 1540579 1541700 1574569 1574571
TreeView+ depends on / blocked
 
Reported: 2018-05-02 13:06 UTC by Ido Ovadia
Modified: 2018-07-30 14:44 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1574569 1574571 (view as bug list)
Environment:
Last Closed: 2018-07-30 14:44:33 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
Error refresh (127.47 KB, image/png)
2018-05-02 13:08 UTC, Ido Ovadia
no flags Details
evm log - Refresh error (30.18 KB, text/plain)
2018-05-02 13:12 UTC, Ido Ovadia
no flags Details

Description Ido Ovadia 2018-05-02 13:06:10 UTC
Description of problem:
=======================
OSPD 12 Undercloud - Infrastructure Provider  refresh failed

ERROR -- : [EmsRefresh::Refreshers::EmsRefresherMixin::PartialRefreshError]: no implicit conversion of nil into Hash  Method:[rescue in deliver]

ERROR -- : /var/www/miq/vmdb/app/models/ems_refresh/refreshers/ems_refresher_mixin.rb:50:in `refresh'


Version-Release number of selected component:
=============================================
RHOS 12, CFME 5.8.4.2

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy RHOS 12 (SSL HA: Undercloud, 3*Controller, 2*Compute)
2. Add Undercloud as Infrastructure provider 
3. Refresh

Actual results:
===============
Refresh Failed with Error -- no implicit conversion of nil into Has

Expected results:
================
Refresh finished successfully

Additional info:
================
Log and screenshots enclosed

Comment 2 Ido Ovadia 2018-05-02 13:08:22 UTC
Created attachment 1430051 [details]
Error refresh

Comment 3 Ido Ovadia 2018-05-02 13:12:40 UTC
Created attachment 1430052 [details]
evm log - Refresh error

Comment 5 CFME Bot 2018-05-03 08:05:17 UTC
New commit detected on ManageIQ/manageiq-providers-openstack/master:

https://github.com/ManageIQ/manageiq-providers-openstack/commit/018d768333be56716cc7025dd0a4a65ccde16614
commit 018d768333be56716cc7025dd0a4a65ccde16614
Author:     Scott Seago <sseago@redhat.com>
AuthorDate: Wed May  2 13:16:23 2018 -0400
Commit:     Scott Seago <sseago@redhat.com>
CommitDate: Wed May  2 13:16:23 2018 -0400

    bz1573893: duplicate opts hash before modifying in raw_connect_try_ssl

    https://bugzilla.redhat.com/show_bug.cgi?id=1573893

    raw_connect_try_ssl modifies the opts hash (pulling out :ssl_options and then
    using it. This means that if raw_connect_try_ssl is called twice with the
    same opts hash, the second time fails because of the side effect of the first
    call. With this change, the method works on a copy of the hash rather than
    the original

 lib/manageiq/providers/openstack/legacy/openstack_handle/handle.rb | 3 +-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comment 9 Dave Johnson 2018-07-30 14:44:33 UTC
Closing this as its already been verified in two z-streams and has test coverage around it.


Note You need to log in before you can comment on or make changes to this bug.