Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573904 - Unable to fetch registry-console image from standalone registry or satellite 6 server.
Summary: Unable to fetch registry-console image from standalone registry or satellite ...
Keywords:
Status: CLOSED DUPLICATE of bug 1516534
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 13:35 UTC by Mahesh Taru
Modified: 2018-05-02 14:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 14:55:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mahesh Taru 2018-05-02 13:35:07 UTC
Created attachment 1430067 [details]
Last task failure

Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

# rpm -q openshift-ansible
openshift-ansible-3.9.14-1.git.3.c62bc34.el7.noarch

# rpm -q ansible
ansible-2.4.4.0-1.el7ae.noarch

# ansible --version
ansible 2.4.4.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Feb 20 2018, 09:19:12) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]

How reproducible:
Always

Steps to Reproduce:
1. On Satellite 6 create docker repositories [a] mentioned in OCP disconnected installation guide [b] and sync them.
2. On OCP master edit the inventory file and add oreg_url as mentioned in documentation [c].
For satellite 6.
***************************
[OSEv3:vars]
oreg_url: satellite.example.com:5000/organization-containers-ose-${component}:${version}
openshift_docker_insecure_registries: "satellite.example.com:5000" 
openshift_docker_additional_registries: "satellite.example.com:5000"
openshift_examples_modify_imagestreams: True
***************************

3. Ensure port 5000 is  open on satellite 6.
4. Perform installation:

# ansible-playbook [-i /path/to/inventory] \
    /usr/share/ansible/openshift-ansible/playbooks/deploy_cluster.yml

[a] https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html-single/content_management_guide/#managing_container_images

[b] https://docs.openshift.com/container-platform/3.9/install_config/install/disconnected_install.html#disconnected-syncing-images

[c] https://docs.openshift.com/container-platform/3.9/install_config/install/disconnected_install.html#diconnected-configuring-registry-location

Actual results:
Installation fails to deploy registry-console pod as the oreg_url only provides access to ose-* images.
Also not able to access other images like logging-*, metrics-*, etc...

Please include the entire output from the last TASK line through the end of output if an error is generated

Attached screen shot.

Expected results:
Installation should succeed with additional services like logging, metrics etc.

Additional info:
It is not clear how to provide variables in order to access other images like logging*, metrics when using satellite6.
Can following work?
***************************
openshift_metrics_image_prefix=satellite.example.com:5000/organization-containers-logging-
openshift_logging_image_prefix=satellite.example.com:5000/organization-containers-metrics-
***************************

Please attach logs from ansible-playbook with the -vvv flag
Attached

Comment 3 Scott Dodson 2018-05-02 14:55:14 UTC

*** This bug has been marked as a duplicate of bug 1516534 ***


Note You need to log in before you can comment on or make changes to this bug.