Bug 1573917 - CRI-O rpm install should be by default
Summary: CRI-O rpm install should be by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.z
Assignee: Chris Evich
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 13:59 UTC by Vikas Laad
Modified: 2018-07-30 19:15 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Obsolete variable required to use CRI-O (tech-preview) in OpenShift. Consequence: Install failure if both variables were not set 'true': openshift_crio_use_rpm and openshift_use_crio. Fix: Remove obsolete variable (openshift_crio_use_rpm), only use openshift_use_crio. Result: Install completes successfully.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:04 UTC

Description Vikas Laad 2018-05-02 13:59:45 UTC
Description of problem:
Using openshift_crio_use_rpm=True tries to install cri-o as system container, since system container install is not preferred anymore can we make openshift_crio_use_rpm=True by default.

Version-Release number of the following components:
3.10

How reproducible:
Always

Steps to Reproduce:
1. use openshift_crio_use_rpm=True

Actual results:
Install tries to install cri-o as system container.

Expected results:
cri-o should be installed as rpm by default.

Additional info:

Comment 2 Daniel Walsh 2018-05-03 19:34:10 UTC
I believe this should belong to the installer team?

Comment 7 Chris Evich 2018-05-21 18:37:17 UTC
By my reading/understanding, ``openshift_crio_use_rpm`` can simply be ignored, since cri-o will always/only be installed as an RPM.  That simplifies the situation to just ``openshift_use_crio``.  Working on a PR to take care of this in the installer (and testing it)...

Comment 8 Chris Evich 2018-05-21 18:45:10 UTC
...actually, it looks like this was already fixed by https://github.com/openshift/openshift-ansible/pull/8427

investigating...

Comment 9 Chris Evich 2018-05-21 20:29:55 UTC
...sure enough, all you need is `openshift_use_crio=true``.

I also confirmed this is upstream under tag ``openshift-ansible-3.10.0-0.50.0`` and master as (4796c1d0).  We'll also give this a final check prior to actual release.

Comment 10 weiwei jiang 2018-05-22 03:15:58 UTC
Checked with 
openshift_ansible_vars:
  openshift_use_crio: true
on 
openshift-ansible-3.10.0-0.50.0.git.0.bd68ade.el7.noarch.rpm
openshift-ansible-docs-3.10.0-0.50.0.git.0.bd68ade.el7.noarch.rpm
openshift-ansible-playbooks-3.10.0-0.50.0.git.0.bd68ade.el7.noarch.rpm
openshift-ansible-roles-3.10.0-0.50.0.git.0.bd68ade.el7.noarch.rpm

and env setup successfully.

# oc version 
oc v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-1-68.ec2.internal:8443
openshift v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8

# oc get nodes -o wide
NAME                           STATUS    ROLES     AGE       VERSION           EXTERNAL-IP    OS-IMAGE                                      KERNEL-VERSION              CONTAINER-RUNTIME                         
ip-172-18-1-68.ec2.internal    Ready     master    3m        v1.10.0+b81c8f8   54.157.36.1    Red Hat Enterprise Linux Server 7.5 (Maipo)   3.10.0-862.2.3.el7.x86_64   cri-o://1.10.2-dev                        
ip-172-18-11-51.ec2.internal   Ready     compute   2m        v1.10.0+b81c8f8   54.209.97.61   Red Hat Enterprise Linux Server 7.5 (Maipo)   3.10.0-862.2.3.el7.x86_64   cri-o://1.10.2-dev

Comment 12 errata-xmlrpc 2018-07-30 19:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.