Bug 1573918 - Dependency failure when installing with DNF
Summary: Dependency failure when installing with DNF
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nwchem
Version: 28
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: marcindulak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1432661
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 14:00 UTC by Henrique C. S. Junior
Modified: 2018-07-04 18:43 UTC (History)
5 users (show)

Fixed In Version: nwchem-6.8.1-4.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-04 18:43:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Henrique C. S. Junior 2018-05-02 14:00:05 UTC
Description of problem:
Can not install NwChem in Fedora 28 using DNF

Version-Release number of selected component (if applicable):
nwchem-*-6.6.27746-32

Steps to reproduce:
dnf install nwchem*
Última verificação de data de vencimento de metadados: 0:25:37 atrás em qua 02 mai 2018 10:31:10 -03.
Erro: 
 Problema 1: conflicting requests
  - nothing provides libgfortran.so.4()(64bit) needed by nwchem-mpich-6.6.27746-32.fc27.x86_64
 Problema 2: conflicting requests
  - nothing provides libgfortran.so.4()(64bit) needed by nwchem-openmpi-6.6.27746-32.fc27.x86_64

Comment 1 marcindulak 2018-05-06 12:27:50 UTC
This related to bug #1514542, the nwchem RPM is old.

Currently https://github.com/nwchemgit/nwchem/issues/41 is preventing me from building nwchem on rawhide.

Moreover, I need to start bundling ga in nwchem RPM, since we cannot rely on Fedora/EPEL providing the right version of ga for every nwchem release (see bug #1432661). I wonder whether there is still any "official" way for approving bundling in Fedora/EPEL.

On f28 you could use https://koji.fedoraproject.org/koji/taskinfo?taskID=26807878 in the meantime. Please test whether scalapack support is compiled properly.

Comment 2 Henrique C. S. Junior 2018-05-12 02:37:54 UTC
Marcin, not only NWChem is broken in Fedora 28. All quantum chemistry packages are: CP2K, quantum-espresso, openmx, exciting...

So far, only Elk is working.

Comment 3 marcindulak 2018-05-12 08:38:24 UTC
As you see from https://github.com/nwchemgit/nwchem/issues/40, we have a problem with nwchem, since it depends on ga, and ga does not seem to be maintained.

I've rebuilt elk manually recently.

If dependencies like gfortran are missing/incorrect then something went wrong with the fedora mass rebuild process which is run at major changes to the compiler packages. For other packages that fail to install you found, please open the corresponding bugs providing the failure for each of them - if the mass rebuild failed, the missing dependencies may be different for each of these packages.

Normally a tracker bug is created in such situations, depending how many components are broken, like this one https://bugzilla.redhat.com/show_bug.cgi?id=1555378, but please don't add to this bug since it's a different problem.

Comment 4 marcindulak 2018-05-28 15:21:59 UTC
We have 8 weeks until nwchem will be orphaned (since bug #1583096 has been submitted).

I won't maintain nwchem without a new ga in Fedora/EPEL.
I've tried to contact the maintainer of ga through bugzilla bug #1432661, without response. Maybe you could try to reach to the maintainer personally by email?

Comment 5 Henrique C. S. Junior 2018-05-28 15:58:57 UTC
I'll give it a try, Marcin. It would be a great loss for Fedora.

Comment 6 Henrique C. S. Junior 2018-06-18 23:00:30 UTC
I have contacted the maintainer. If everything fails would you consider maintaining a COPR for Nwchem?

Comment 7 marcindulak 2018-06-19 07:30:22 UTC
edoapra prepared an updated ga.spec https://github.com/edoapra/fedpkg, and I'm trying to take over ga maintenance according to https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers, currently at step 5.

Comment 8 Henrique C. S. Junior 2018-06-20 18:33:16 UTC
I have received a reply from David.

"I’ve not had time to make the required updates for GA and I don’t foresee being able to continue maintaining the package. If you would like to take it over feel free to start the process.
Thanks"

Thanks for taking the package, Marcin.

Comment 9 marcindulak 2018-06-20 19:16:15 UTC
Thanks, since you managed to establish a contact with David, could you ask him to add me (marcindulak) as ga co-maintainer? This setting is available directly at https://src.fedoraproject.org/rpms/ga/settings instead of going through the drastic https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers.

Comment 10 Henrique C. S. Junior 2018-06-20 23:22:05 UTC
Done.

Comment 11 Fedora Update System 2018-07-02 11:01:38 UTC
nwchem-6.8.1-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dccd733c0a

Comment 12 Fedora Update System 2018-07-03 17:53:24 UTC
nwchem-6.8.1-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dccd733c0a

Comment 13 Fedora Update System 2018-07-04 18:43:45 UTC
nwchem-6.8.1-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.