Bug 1573961 - Jabberd won't start with libidn-1.34
Summary: Jabberd won't start with libidn-1.34
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libidn
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 15:21 UTC by Scott Baker
Modified: 2018-05-22 15:06 UTC (History)
4 users (show)

Fixed In Version: libidn-1.34-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-22 15:06:04 UTC


Attachments (Terms of Use)

Description Scott Baker 2018-05-02 15:21:13 UTC
Description of problem:
Rebooted my Fedora 27 server and jabberd wouldn't start after. After some digging in the log files I found the following errors:

May  2 02:45:11 perturb c2s[5522]: /usr/bin/c2s: Symbol `stringprep_xmpp_nodeprep' has different size in shared object, consider re-linking
May  2 02:45:11 perturb c2s[5522]: /usr/bin/c2s: Symbol `stringprep_xmpp_resourceprep' has different size in shared object, consider re-linking
May  2 02:45:11 perturb c2s[5522]: /usr/bin/c2s: Symbol `stringprep_nameprep' has different size in shared object, consider re-linking
May  2 02:45:11 perturb s2s[5523]: /usr/bin/s2s: Symbol `stringprep_nameprep' has different size in shared object, consider re-linking
May  2 02:45:11 perturb sm[5524]: /usr/bin/sm: Symbol `stringprep_nameprep' has different size in shared object, consider re-linking

Some Googling told me that function is part of libidn. I did a "yum downgrade libidn" and it reverted to 1.33 and I was able to start jabberd again. I assume this is a libidn bug and not a jabberd bug? I might be wrong though.

Version-Release number of selected component (if applicable):
Works : libidn-1.33-4.fc27.x86_64
Broken: libidn-1.34-1.fc27.x86_64

How reproducible:
Easily

Steps to Reproduce:
1. Attempt to start jabberd with libidn-1.34
2. Note the failure
3. Profit

Comment 1 Miroslav Lichvar 2018-05-02 15:25:36 UTC
An issue related to stringprep_nameprep and jabberd was reported in bug #1566414. Maybe one can explain the other.

Comment 2 Miroslav Lichvar 2018-05-02 15:59:20 UTC
It looks like there was an ABI break in libidn-1.34 due to:
http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=518b72c7273278d24cb79ac1485972e42cf98ed4

Could you please try the following test package, which reverts that change, and see if the problem disappears?

https://koji.fedoraproject.org/koji/taskinfo?taskID=26729407

However, I'm not sure what should we do here. If some packages were already rebuilt with the new libidn, they will break if we revert that change back. I suspect we have the same problem in Fedora 28. libidn was updated to 1.34 after the F28 mass rebuild.

Comment 3 Fedora Update System 2018-05-04 11:30:54 UTC
libidn-1.34-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-25d5c86330

Comment 4 Fedora Update System 2018-05-04 11:31:13 UTC
libidn-1.34-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 5 Scott Baker 2018-05-04 14:10:14 UTC
I just installed libidn-1.34-2.fc28 and now jabberd *will* start. I'd live to give it a full day worth of testing before I saw for sure, but initially this looks like a good fix.

Comment 6 Fedora Update System 2018-05-06 10:07:51 UTC
libidn-1.34-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 7 Fedora Update System 2018-05-06 21:53:28 UTC
libidn-1.34-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-25d5c86330

Comment 8 Fedora Update System 2018-05-10 15:19:31 UTC
libidn-1.34-2.fc27 mcabber-1.1.0-1.fc27.1 pidgin-2.13.0-1.fc27.1 python-slixmpp-1.3.0-5.fc27.1 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-25d5c86330

Comment 9 Fedora Update System 2018-05-10 15:20:38 UTC
ghostscript-9.23-2.fc28.1 libidn-1.34-2.fc28 mcabber-1.1.0-1.fc28.1 pidgin-2.13.0-1.fc28.1 python-slixmpp-1.3.0-5.fc28.1 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 10 Fedora Update System 2018-05-11 17:36:40 UTC
libidn-1.34-2.fc27, mcabber-1.1.0-1.fc27.1, pidgin-2.13.0-1.fc27.1, python-slixmpp-1.3.0-5.fc27.1 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-25d5c86330

Comment 11 Fedora Update System 2018-05-11 18:51:03 UTC
ghostscript-9.23-2.fc28.1, libidn-1.34-2.fc28, mcabber-1.1.0-1.fc28.1, pidgin-2.13.0-1.fc28.1, python-slixmpp-1.3.0-5.fc28.1 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 12 Fedora Update System 2018-05-15 13:58:15 UTC
ghostscript-9.23-4.fc28 libidn-1.34-3.fc28 mcabber-1.1.0-1.fc28.1 pidgin-2.13.0-1.fc28.1 python-slixmpp-1.3.0-5.fc28.1 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 13 Fedora Update System 2018-05-15 23:02:19 UTC
ghostscript-9.23-4.fc28, libidn-1.34-3.fc28, mcabber-1.1.0-1.fc28.1, pidgin-2.13.0-1.fc28.1, python-slixmpp-1.3.0-5.fc28.1 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 14 Fedora Update System 2018-05-22 15:06:04 UTC
ghostscript-9.23-4.fc28, libidn-1.34-3.fc28, mcabber-1.1.0-1.fc28.1, pidgin-2.13.0-1.fc28.1, python-slixmpp-1.3.0-5.fc28.1 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.