Bug 1573965 - The GUI displays the roles from the "overcloud" plan even if you switched to a custom plan
Summary: The GUI displays the roles from the "overcloud" plan even if you switched to ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ga
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 15:29 UTC by Udi
Modified: 2018-06-27 13:55 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-20.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:54:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:55:51 UTC

Description Udi 2018-05-02 15:29:57 UTC
Description of problem:
I created and deleted roles in the "roles/" subdirectory in the plans, and updated the swift container. In the GUI, I couldn't see the changes even after pressing F5 several times.

When I repeated the test for the default "overcloud" plan - the GUI behaved correctly. However, I could then see the changes I made in the "overcloud" plan also in the other plans...


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Create a role yaml file under the "roles/" subdirectory in the plans. I copied an existing role:  Networker.yaml NetworkerNetworker.yaml
2. Edit the name of the new role so it will be unique
3. Upload the new role to swift: openstack object create <<plan-name>> roles/NetworkerNetworker.yaml
4. In the GUI, open the manage roles dialog and look for the role


Actual results:
Role is not found. It will only work if <<plan-name>> is the default "overcloud" plan, and then you'll see the changes in all other plans as well. It seems like the dialog doesn't pass the plan name correctly and always displays the roles of "overcloud".

Comment 2 Udi 2018-06-10 06:52:06 UTC
Raising the severity of this bug. A lot of bugs are being opened around this issue. For example, if a user deletes the "overcloud" plan - the user gets nasty error messages when trying to open the roles management dialog. Also, users are complaining that they add custom roles to their plans and don't see them in the dialog...

Comment 3 Jiri Tomasek 2018-06-11 10:38:19 UTC
This bug is caused by the same reasons as bugs mentioned here https://bugzilla.redhat.com/show_bug.cgi?id=1588838. Fixes for these should also fix this one.

Comment 4 Jiri Tomasek 2018-06-13 07:25:38 UTC
Fixes for both related bugs are now merged and available.

Comment 6 Jason E. Rist 2018-06-13 15:05:57 UTC
See previous

Comment 11 Udi 2018-06-18 13:44:53 UTC
Verified: openstack-tripleo-ui-8.3.1-3.el7ost.noarch

Comment 13 errata-xmlrpc 2018-06-27 13:54:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.