Bug 1573981 - Clipboard freezes when KVM/QEMU VM window is opened using virt-manager
Summary: Clipboard freezes when KVM/QEMU VM window is opened using virt-manager
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-plasma
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 16:03 UTC by Adam
Modified: 2019-05-28 20:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 20:01:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam 2018-05-02 16:03:46 UTC
Description of problem:
Tested on F26-27-28

Recently I powered on older laptop with Fedora 26 with KDE Plasma that hasn’t been updated for some time. After update I quickly realized that there is something wrong with clipboard.

On F26 without updates I was used to open multiple local KVM/QEMU VMs via virt-manager and for example one or two VMs on remote host over LAN and everything worked well - Windows VMs with installed Spice drivers and Fedora 26 VMs that have spice-vdagent installed by default. Copy & pasting text between VMs or just within host worked just fine.

Then I updated F26 host. Clipboard worked just fine until I opened some VM windows. After that clipboard freezes time to time when pasting. Sometime pasting just don’t work and sometime when you press Ctrl + V all keyboard inputs freeze and keyboard simple stop working for a couple of seconds. The only workaround is to close VM windows.

This is extremely irritating since you never know if Paste will or won’t work. I also tested this issue on F27 and F28. They all have this issue.

Version-Release number of selected component (if applicable):
Everything is OK for:
plasma-*-5.10.5
kf5-*-5.35.0 / 17.04.1
qt5-*-5.7.1

Steps to Reproduce:
1. Install F26 KDE Plasma, do not update
2. Run multiple VMs, some with F26 KDE Plasma, some with Windows with Spice drivers
3. Open virt-manager VM windows
4. Copy and paste in host inside for example Kate or between host and VM – everything works just fine
5. Update F26 host
6. Again copy/cut and paste – paste sometime won’t work and sometime it will also freeze keyboard for a couple of seconds
7. Close VM windows
8. Everything is OK again

Comment 1 Ben Cotton 2019-05-02 21:53:01 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Ben Cotton 2019-05-28 20:01:55 UTC
Fedora 28 changed to end-of-life (EOL) status on 2019-05-28. Fedora 28 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.