Bug 1574153 - NetworkManager crash on kernel 4.16.4 and 4.16.5
Summary: NetworkManager crash on kernel 4.16.4 and 4.16.5
Keywords:
Status: CLOSED DUPLICATE of bug 1572872
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 18:01 UTC by Phil Wiggum
Modified: 2018-08-05 18:38 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-05 18:38:00 UTC
Type: Bug


Attachments (Terms of Use)
Logs, ixgbe and NetworkManager 4.15.17 and 4.16.5 (29.61 KB, text/plain)
2018-05-02 18:01 UTC, Phil Wiggum
no flags Details
Logs, dhcp, nmdb and NetworkManager 4.15.17 and 4.16.5.log (28.06 KB, text/plain)
2018-05-03 18:37 UTC, Phil Wiggum
no flags Details

Description Phil Wiggum 2018-05-02 18:01:07 UTC
Created attachment 1430232 [details]
Logs, ixgbe and NetworkManager 4.15.17 and 4.16.5

I get no ethernet connection with latest dnf upgrade.

Fedora 27 Server.
MB: Supermicro - A2SDi-8C-HLN4F (4 Ethernet con.)
CPU: Intel C3758 (8cores)
Memory 16GB

Kernel 4.15.17 runs fine without any problems.


May  2 18:43:08 server1 NetworkManager[1075]: <info>  [1525279388.7593] dhcp4 (eno1): dhclient started with pid 1482
May  2 18:43:15 server1 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May  2 18:43:34 server1 systemd[1]: NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE
May  2 18:43:34 server1 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=NetworkManager-wait-online comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
May  2 18:43:34 server1 systemd[1]: NetworkManager-wait-online.service: Unit entered failed state.
May  2 18:43:34 server1 systemd[1]: NetworkManager-wait-online.service: Failed with result 'exit-code'.
May  2 18:43:40 server1 NetworkManager[1075]: <info>  [1525279420.3408] ModemManager disappeared from bus

Comment 1 Thomas Haller 2018-05-03 13:25:19 UTC
there is no crash visible in the logfile.

it's also not visible what exactly happens so that you "get no ethernet connection".

Comment 2 Phil Wiggum 2018-05-03 18:37:38 UTC
Created attachment 1430850 [details]
Logs, dhcp, nmdb and NetworkManager 4.15.17 and 4.16.5.log

dhcp fault.

Comment 3 Phil Wiggum 2018-05-03 18:43:50 UTC
(In reply to Thomas Haller from comment #1)

Yes, no actual crash but a failure.

Look at May 2 18:43:34 server1 systemd[1]: NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE

Seems to be due dhcp can't get any data.
see:  Logs, dhcp, nmdb and NetworkManager 4.15.17 and 4.16.5.log 

Question is why it is working in 4.15.17 and not in 4.16.4/4.16.5.

Comment 4 Phil Wiggum 2018-05-03 18:56:17 UTC
grep dhc 'Logs, dhcp, nmdb and NetworkManager 4.15.17 and 4.16.5.log'

4.16.5:
DHCPREQUEST
DHCPREQUEST
DHCPDISCOVER
DHCPDISCOVER
DHCPDISCOVER 

4.15.17:
DHCPREQUEST
DHCPREQUEST
DHCPACK

Comment 5 Phil Wiggum 2018-08-05 18:38:00 UTC
Cause same as 1572872 
On 4.17.11-100.fc27.x86_64
https://bugzilla.redhat.com/show_bug.cgi?id=1572872

*** This bug has been marked as a duplicate of bug 1572872 ***


Note You need to log in before you can comment on or make changes to this bug.