Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574165 - st-user 0.8.1-1 cannot build custom st because install is missing new source files
Summary: st-user 0.8.1-1 cannot build custom st because install is missing new source ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: st
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 18:20 UTC by unstoppable.tapir
Modified: 2018-05-19 22:24 UTC (History)
2 users (show)

Fixed In Version: st-0.8.1-2.fc28 st-0.8.1-2.fc27 st-0.8.1-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-19 21:23:57 UTC
Type: Bug


Attachments (Terms of Use)

Description unstoppable.tapir 2018-05-02 18:20:49 UTC
Description of problem:
st-user 0.8.1-1 cannot build a user copy of st because the installed source code is missing new files introduced in version 0.8

Version-Release number of selected component (if applicable):
st-user-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
1. Create a custom st config (e.g. with "mkdir ~/.st; cp /usr/src/st-0.8.1-1.fc28/config.def.h ~/.st/config.h")
2. Run "st-user"

Actual results:
> st-user: Rebuilding st...
> make: *** No rule to make target 'st.h', needed by 'st.o'.  Stop.
> st-user: Build failed.  See /home/neal/.st-build/build.log for details.
> st-user: Running user st...

(In this case, it's still running a previously compiled custom build of 0.7-4)

Expected results:
Custom build of st succeeds and is run

Additional info:
It looks like the only change that needs to be made is in the .spec file, changing this line:
> install -m644 arg.h config.def.h config.mk Makefile st.c st.info \
to:
> install -m644 arg.h config.def.h config.mk Makefile st.c st.h st.info win.h x.c \

Comment 1 Petr Šabata 2018-05-10 07:12:09 UTC
Thanks for the report.  I simplified the suggested change a bit.
Updates are on the way.

Comment 2 Fedora Update System 2018-05-10 07:13:32 UTC
st-0.8.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ca75371245

Comment 3 Fedora Update System 2018-05-10 07:13:42 UTC
st-0.8.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae703ce4d

Comment 4 Fedora Update System 2018-05-10 07:13:47 UTC
st-0.8.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-96813c068c

Comment 5 Fedora Update System 2018-05-10 20:01:17 UTC
st-0.8.1-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ca75371245

Comment 6 Fedora Update System 2018-05-11 00:48:28 UTC
st-0.8.1-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-96813c068c

Comment 7 Fedora Update System 2018-05-11 01:59:32 UTC
st-0.8.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae703ce4d

Comment 8 Fedora Update System 2018-05-19 21:23:57 UTC
st-0.8.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-05-19 21:34:25 UTC
st-0.8.1-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-05-19 22:24:28 UTC
st-0.8.1-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.