Bug 1574174 - SELinux is preventing ifconfig from 'getattr' accesses on the file /proc/<pid>/net/dev.
Summary: SELinux is preventing ifconfig from 'getattr' accesses on the file /proc/<pid...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8747963f8511a95788e896f596c...
: 1574169 1574172 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 18:25 UTC by Anass Ahmed
Modified: 2018-05-26 20:45 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.14.1-29.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-26 20:45:50 UTC
Type: ---


Attachments (Terms of Use)

Description Anass Ahmed 2018-05-02 18:25:07 UTC
Description of problem:
Trying to connect to SSH Tunnel using GNOME Network Manager SSH plugin.
SELinux is preventing ifconfig from 'getattr' accesses on the file /proc/<pid>/net/dev.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ifconfig should be allowed getattr access on the dev file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ifconfig' --raw | audit2allow -M my-ifconfig
# semodule -X 300 -i my-ifconfig.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_ssh_t:s0
Target Context                system_u:object_r:proc_net_t:s0
Target Objects                /proc/<pid>/net/dev [ file ]
Source                        ifconfig
Source Path                   ifconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-05-02 20:12:28 EET
Last Seen                     2018-05-02 20:12:28 EET
Local ID                      fb932568-7f3b-46b0-a9c1-494174974cba

Raw Audit Messages
type=AVC msg=audit(1525284748.649:460): avc:  denied  { getattr } for  pid=14072 comm="ifconfig" path="/proc/14072/net/dev" dev="proc" ino=4026532029 scontext=system_u:system_r:NetworkManager_ssh_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file permissive=1


Hash: ifconfig,NetworkManager_ssh_t,proc_net_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-05-21 14:25:58 UTC
*** Bug 1574172 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2018-05-21 14:26:03 UTC
*** Bug 1574169 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-05-24 14:38:28 UTC
selinux-policy-3.14.1-29.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 4 Fedora Update System 2018-05-25 18:44:04 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a74875b364

Comment 5 Fedora Update System 2018-05-26 20:45:50 UTC
selinux-policy-3.14.1-29.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.