Bug 1574182 - SELinux is preventing ssh from 'open' accesses on the chr_file /dev/net/tun.
Summary: SELinux is preventing ssh from 'open' accesses on the chr_file /dev/net/tun.
Keywords:
Status: CLOSED DUPLICATE of bug 1574184
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9d06c7c9f0c3a6d26d3b5fa666e...
: 1660640 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 18:30 UTC by Anass Ahmed
Modified: 2019-01-09 09:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 14:27:51 UTC
Type: ---


Attachments (Terms of Use)

Description Anass Ahmed 2018-05-02 18:30:52 UTC
Description of problem:
Trying to connect to SSH Tunnel using GNOME Network Manager SSH plugin.
SELinux is preventing ssh from 'open' accesses on the chr_file /dev/net/tun.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ssh should be allowed open access on the tun chr_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ssh' --raw | audit2allow -M my-ssh
# semodule -X 300 -i my-ssh.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_ssh_t:s0
Target Context                system_u:object_r:tun_tap_device_t:s0
Target Objects                /dev/net/tun [ chr_file ]
Source                        ssh
Source Path                   ssh
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-05-02 20:12:29 EET
Last Seen                     2018-05-02 20:12:29 EET
Local ID                      5276b6bd-90c9-486e-9789-76847b7a76c9

Raw Audit Messages
type=AVC msg=audit(1525284749.683:466): avc:  denied  { open } for  pid=14075 comm="ssh" path="/dev/net/tun" dev="devtmpfs" ino=1339 scontext=system_u:system_r:NetworkManager_ssh_t:s0 tcontext=system_u:object_r:tun_tap_device_t:s0 tclass=chr_file permissive=1


Hash: ssh,NetworkManager_ssh_t,tun_tap_device_t,chr_file,open

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-05-21 14:27:51 UTC

*** This bug has been marked as a duplicate of bug 1574184 ***

Comment 2 Lukas Vrabec 2019-01-09 09:21:27 UTC
*** Bug 1660640 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.