Bug 157423 - Unable to change monitor model (Python traceback)
Unable to change monitor model (Python traceback)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-11 11:15 EDT by Derek Poon
Modified: 2014-06-18 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 16:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Poon 2005-05-11 11:15:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
Once the monitor type has been selected in the installer, it cannot be changed through the UI.  All subsequent clicks on the "Configure" button in the Monitor section result in nothing happening.

Version-Release number of selected component (if applicable):
system-config-display-1.0.27-1

How reproducible:
Always

Steps to Reproduce:
1. During install/firstboot, I chose "LCD Panel (1280x1024)" as the Monitor Type.
2. Immediately realizing my mistake (intending to choose 1024x768), I tried to fix it, but nothing happens when I click on the "Configure" button.
3. Going with the flow... after install, I launch GNOME in a low resolution, and run Desktop -> System Settings -> Display.
4. Again, nothing happens when I click on Configure.
  

Actual Results:  Clicking on "Configure" should show the dialog to select the monitor type.

Expected Results:  Nothing happens, because of the following Python error:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 334, in configure_monitor
    self.monitor_dialog.goto_path()
  File "/usr/share/system-config-display/monitorDialog.py", line 93, in goto_path
    self.ok_button.set_sensitive(gtk.True)
AttributeError: 'module' object has no attribute 'True'

Additional info:

This patch fixes it.

--- ./monitorDialog.py.monitor  2005-04-28 23:29:44.000000000 +0200
+++ ./monitorDialog.py  2005-05-11 16:45:40.000000000 +0200
@@ -90,7 +90,7 @@
             if self.monitor_store.iter_depth(iter) == 0:
                 self.ok_button.set_sensitive(False)
             else:
-                self.ok_button.set_sensitive(gtk.True)
+                self.ok_button.set_sensitive(True)

             self.changing_selection = 0
             self.tree_view.set_cursor(self.probed_path, self.col, FALSE)
Comment 1 Tachus Tachus 2005-05-11 13:26:43 EDT
patch works ok, thanks
Comment 2 Jeremy Katz 2005-05-23 19:25:22 EDT
Fixed in 1.0.28

Note You need to log in before you can comment on or make changes to this bug.