Bug 1574259 - Errors unintentionally reported for snapshot status
Summary: Errors unintentionally reported for snapshot status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 23:03 UTC by Thomas H.P. Andersen
Modified: 2018-06-20 18:05 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:05:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
ignore errors from VOL/ALL (1.40 KB, patch)
2018-05-02 23:16 UTC, Thomas H.P. Andersen
no flags Details | Diff

Description Thomas H.P. Andersen 2018-05-02 23:03:38 UTC
Description of problem:

Errors are reported for snapshot status of type ALL and VOL. The intention was to ignore those, but the code gets it wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Noticed when checking a warning in smatch, so not reproducible.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

The condition on ALL/VOL was removed in
BUG: 1096610
Change-Id: Ifc0ac31d2a9f91e136e87f3b51a629df7dba94e8

And the current logic introduced in
BUG: 789278
Change-Id: I985cea1ef787d239b2632d5a7f467070846f92e4

Comment 1 Thomas H.P. Andersen 2018-05-02 23:16:20 UTC
Created attachment 1430369 [details]
ignore errors from VOL/ALL

The rfc.sh script does not seem to let me push the patch to gerrit, so I attach it here.

Comment 2 Thomas H.P. Andersen 2018-05-02 23:29:28 UTC
I tried to follow the guide to submit the patch but I get this error from rfc.sh:

$ ./rfc.sh 
Running coding guidelines check ...
Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^(\+.*(?:do|\))){ <-- HERE / at ./build-aux/checkpatch.pl line 3102.
[detached HEAD 3cc620f1b] cli/snapshot: ignore errors for snapshot status for ALL/VOL
 Date: Thu May 3 00:58:02 2018 +0200
 1 file changed, 1 insertion(+), 1 deletion(-)
Successfully rebased and updated refs/heads/cli-ignore-errors-vol-all.
error: src refspec 1574259 does not match any.
error: failed to push some refs to 'ssh://phomes@review.gluster.org/glusterfs'

I gave the script this bugs ID (just '1574259') when it requested a bugzilla ID.

The patch is also on my github clone if that helps in any way:
https://github.com/phomes/glusterfs/tree/cli-ignore-errors-vol-all

Comment 3 Worker Ant 2018-05-03 12:08:30 UTC
REVIEW: https://review.gluster.org/19956 (cli/snapshot: ignore errors for snapshot status for ALL/VOL) posted (#1) for review on master by Kaleb KEITHLEY

Comment 4 Worker Ant 2018-05-03 16:03:39 UTC
REVIEW: https://review.gluster.org/19958 (cli/snapshot: ignore errors for snapshot status for ALL/VOL) posted (#1) for review on master by Thomas H.P. Andersen

Comment 5 Worker Ant 2018-05-04 04:50:18 UTC
COMMIT: https://review.gluster.org/19958 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- cli/snapshot: ignore errors for snapshot status for ALL/VOL

Currently errors are reported for snapshot status of type ALL and VOL.
The intention was to ignore those, but the code gets it wrong.

The original condition for ignoring ALL/VOL was removed in
   Bug 1096610
   Change-Id Ifc0ac31d2a9f91e136e87f3b51a629df7dba94e8

And the current logic introduced in
   Bug 789278
   Change-Id I985cea1ef787d239b2632d5a7f467070846f92e4

Change-Id: Ic02ea98fb23b1149264e91b41f2fc2ca916d405f
Fixes: bz#1574259
Signed-off-by: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>

Comment 6 Shyamsundar 2018-06-20 18:05:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.