Bug 1574334 - Wired connection / ethernet state DOWN after wakeup from suspend
Summary: Wired connection / ethernet state DOWN after wakeup from suspend
Keywords:
Status: CLOSED DUPLICATE of bug 1580079
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 05:23 UTC by krinkodot22
Modified: 2018-05-19 21:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-19 21:54:47 UTC
Type: Bug


Attachments (Terms of Use)
Outputs of the requested commands, using "enp3s0" as IFNAME. (22.58 KB, application/x-gzip)
2018-05-04 03:55 UTC, krinkodot22
no flags Details

Description krinkodot22 2018-05-03 05:23:50 UTC
Description of problem:
After suspending my laptop & waking it up, it loses the ability to use a wired network connection via its Ethernet port. `ip addr` says that the state of enp3s0 is DOWN, and trying to bring it back up with ifup fails with "Error: Connection activation failed: No suitable device found for this connection." In Gnome Settings, Network->Wired says "Cable unplugged". Overall, the computer behaves as though it has no Ethernet port at all.


Version-Release number of selected component (if applicable):
NetworkManager-1.10.6-2.fc28.x86_64


How reproducible:
Always, but it is likely a hardware-dependent issue.


Steps to Reproduce:
1. Boot your computer with Ethernet plugged in
2. Suspend the computer
3. Wake it up


Actual results:
A wired network connection is not available; see the first paragraph of this post. WiFi remains available, though.


Expected results:
A wired connection should be available: `ip addr` should show the wired connection's state as UP; Gnome Shell should show a Wired Connection available; etc


Additional info:
This also happened to me on Fedora 27 as of a few months ago. Upgrading to F28 didn't fix it. It is also hardware-dependent, as it doesn't happen on another laptop of mine.

Please let me know of any other information/logs I should post here to help debug this.

Comment 1 Beniamino Galvani 2018-05-03 07:24:54 UTC
Please reproduce the problem and then attach the output of:

dmesg

ip link

nmcli -f all device show $IFNAME

ethtool $IFNAME

Comment 2 krinkodot22 2018-05-04 03:55:48 UTC
Created attachment 1431001 [details]
Outputs of the requested commands, using "enp3s0" as IFNAME.

Comment 3 Francesco Giudici 2018-05-04 12:21:48 UTC
Seems like your Ethernet card does not detect the carrier after suspend.

I guess removing and adding back the kernel module could be of help:
sudo modprobe -r r8169
sudo modprobe r8169

You may want to reopen bug 1312006.

Comment 4 krinkodot22 2018-05-05 22:00:41 UTC
Restarting the module did bring my wired connection back up, thanks. I'll reopen that bug & mark this one as a duplicate.

Comment 5 krinkodot22 2018-05-19 21:54:47 UTC
I mustn't have permissions to reopen bugs, so I cloned bug 1312006 instead of reopening it.

*** This bug has been marked as a duplicate of bug 1580079 ***


Note You need to log in before you can comment on or make changes to this bug.