Bug 1574349 - [OSP13] Allow fencing to be done before deployment
Summary: [OSP13] Allow fencing to be done before deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: All
OS: All
medium
medium
Target Milestone: z2
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: Marian Krcmarik
URL:
Whiteboard:
: 1598413 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 06:19 UTC by Michele Baldessari
Modified: 2018-12-24 11:40 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-common-8.6.3-2.el7ost
Doc Type: Enhancement
Doc Text:
It is possible to create the stonith resources for the cluster automatically before the overcloud deployment. Before the start of the deployment, run the following command: openstack overcloud generate fencing --ipmi-lanplus --output /home/stack/fencing.yaml /home/stack/instackenv.json Then pass '-e /home/stack/fencing.yaml' to the list of arguments to the deploy command. This creates the necessary stonith resources for the cluster automatically.
Clone Of:
Environment:
Last Closed: 2018-08-29 16:35:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 566554 0 None MERGED Allow fencing config generation before deployment. 2020-12-11 19:41:54 UTC
Red Hat Product Errata RHBA-2018:2574 0 None None None 2018-08-29 16:36:50 UTC

Description Michele Baldessari 2018-05-03 06:19:53 UTC
Description of problem:
Currently the 'overcloud generate fencing' command can only be run after a successful deployment. Now that we moved to IPMI for CI and BM we should be able to do it before the deployment as well.

Comment 1 Michele Baldessari 2018-05-08 10:33:36 UTC
queens merged

Comment 3 pkomarov 2018-07-05 12:17:56 UTC
*** Bug 1598413 has been marked as a duplicate of this bug. ***

Comment 14 Joanne O'Flynn 2018-08-15 07:51:26 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 16 errata-xmlrpc 2018-08-29 16:35:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574


Note You need to log in before you can comment on or make changes to this bug.