Bug 1574390 - mod_fcgid fails at startup with F28
Summary: mod_fcgid fails at startup with F28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_fcgid
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 08:01 UTC by Joe Orton
Modified: 2018-05-12 18:20 UTC (History)
2 users (show)

Fixed In Version: mod_fcgid-2.3.9-15.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-12 18:20:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Joe Orton 2018-05-03 08:01:25 UTC
Description of problem:
mod_fcgid is failing at startup due to 

Version-Release number of selected component (if applicable):
mod_fcgid-2.3.9-11.fc28.x86_64

How reproducible:
always

Steps to Reproduce:
1. dnf install -y mod_fcgid && systemctl restart httpd

Actual results:
fails

Expected results:
success

Additional info:
tail -n1 /var/log/httpd/error_log
type=AVC msg=audit(1522948237.702:805): avc:  denied  { dac_override } for  pid=23876 comm="httpd" capability=1  scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:system_r:httpd_t:s0 tclass=capability permissive=0

Comment 1 Fedora Update System 2018-05-03 10:15:20 UTC
mod_fcgid-2.3.9-15.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ce5feae6ac

Comment 2 Fedora Update System 2018-05-03 20:23:57 UTC
mod_fcgid-2.3.9-15.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ce5feae6ac

Comment 3 Fedora Update System 2018-05-12 18:20:17 UTC
mod_fcgid-2.3.9-15.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.