Bug 1574396 - Utilization for random entities giving unexpected error for Record Not Found
Summary: Utilization for random entities giving unexpected error for Record Not Found
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.z
Assignee: Hilda Stastna
QA Contact: Nikhil Dhandre
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 08:14 UTC by Nikhil Dhandre
Modified: 2019-02-18 14:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 14:56:12 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Nikhil Dhandre 2018-05-03 08:14:15 UTC
Created attachment 1430554 [details]
log.tar.gz

Description of problem:
-----------------------
When I tried to open Utilization Page for some random entities like Host, VM unexpected error occurring. It is not able to reproduce every time however I have seen this three times before. Mostly second time I am able to access entities utilization page.

Yes, it is one of the possibility that record not found for the specific chart, but I am able to access the same thing the second time. Also, we have functionality that 'Utilization' tab active only if metrics available (It should be disabled in case record not available). 


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Version 5.9.2.4.20180501195858_35dc609



How reproducible:
-----------------
Not always (10-20% times, I guess!)


Steps to Reproduce:
-------------------
1. Navigate to VM or Host
2. Try to open Utilization Page (Monitoring > Utilization)


Actual results:
---------------
It is raising an unexpected error.

ActiveRecord::RecordNotFound] Couldn't find MiqTask with 'id'=123

Expected results:
-----------------
It should not raise an unexpected error as I am able to access the same page the second time. 


Additional info:
----------------
Attaching logs and snapshot of an unexpected error.

Comment 7 Hilda Stastna 2019-02-18 14:37:03 UTC
This bug is not reproducible in latest release.


Note You need to log in before you can comment on or make changes to this bug.