Bug 1574401 - [Packaging] ODL RPM contains so's inside jars embedded in narayana-osgi-jta
Summary: [Packaging] ODL RPM contains so's inside jars embedded in narayana-osgi-jta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Mike Kolesnik
QA Contact: Jon Schlueter
URL:
Whiteboard: odl_packaging
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 08:25 UTC by Mike Kolesnik
Modified: 2018-10-18 07:20 UTC (History)
5 users (show)

Fixed In Version: opendaylight-8.0.0-10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:49 UTC

Description Mike Kolesnik 2018-05-03 08:25:36 UTC
Description of problem:
The RPM contains so's inside jars that are inside the narayana-osgi-jta jar, this causes RPMDiff to fail: https://rpmdiff.engineering.redhat.com/run/222556/4/

We should remove the so's or this jar altogether from the RPM


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Mike Kolesnik 2018-05-03 08:30:32 UTC
After analysing the RPM and the use of this jar, it seems it's brought in by a feature that's bundled with karaf, but this feature is never loaded by the netvirt feature we install, so it snould be safe to simply delete these jars from the RPM altogether.

Comment 8 Jon Schlueter 2018-05-03 20:08:41 UTC
Verified rpmdiff warnings cleared for this build.

Comment 10 errata-xmlrpc 2018-06-27 13:55:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.