Bug 1574421 - Provide a way to get the hashed-subvol for a file
Summary: Provide a way to get the hashed-subvol for a file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 09:26 UTC by Nithya Balachandran
Modified: 2018-10-23 15:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-03 09:26:48 UTC
Description of problem:

There is currently no easy way to get the hashed subvol for a file on a gluster volume.


Provide a virtual xattr to query the hashed subvol of a file.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-05-04 05:11:08 UTC
REVIEW: https://review.gluster.org/19961 (cluster/dht:  Debug virtual xattrs for dht) posted (#1) for review on master by N Balachandran

Comment 2 Worker Ant 2018-05-09 03:47:03 UTC
COMMIT: https://review.gluster.org/19961 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht:  Debug virtual xattrs for dht

Provide a virtual xattr with which to query
the hashed subvol for a file.

Change-Id: Ic7abd031f875da4b9084841ea7c25d6c8a851992
fixes: bz#1574421
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.