Bug 1574443 - [RFE] Allow host to be forcefully flipped to maintenance using power management restart
Summary: [RFE] Allow host to be forcefully flipped to maintenance using power manageme...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: Artur Socha
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1670329 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 10:50 UTC by Roman Hodain
Modified: 2020-05-25 11:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, it was problematic to flip the host into the maintenance state while it was flipping between connecting and activating state. In this release, the host, regardless of its initial state before restart, will be put into maintenance mode after restarting the host using power management configuration.
Clone Of:
Environment:
Last Closed: 2020-05-20 20:00:53 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.4+
mtessun: planning_ack+
mperina: devel_ack+
lleistne: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 103171 0 'None' MERGED core: go to maintenance on restart 2021-01-29 08:53:42 UTC
oVirt gerrit 103213 0 'None' MERGED webadmin: enable maintenance on host after restart 2021-01-29 08:53:42 UTC
oVirt gerrit 103234 0 'None' MERGED Host service: maintenance_after_restart flag 2021-01-29 08:53:42 UTC
oVirt gerrit 103262 0 'None' MERGED restapi: put host to maintenance on pm restart 2021-01-29 08:54:26 UTC
oVirt gerrit 103307 0 'None' MERGED restapi: Update to model 4.4.8 2021-01-29 08:53:42 UTC

Description Roman Hodain 2018-05-03 10:50:48 UTC
Description of problem:
It is not possible to flip a host to the maintenance mode in case it is connecting or activating. It is understood that some status simply cannot be interrupted a host cannot be flipped to the maintenance mode immediately, but it should be possible to flip the host to the maintenance in the nearest possible state.
It is problematic to flip the host to the maintenance state if it is flipping between connecting and activating state. It may get to the non-operation state for short period of time, but one has to monitor the host and click the button as soon as itis in the non-operational state otherwise the host can flip to connecting again.

Comment 1 Martin Perina 2018-05-16 11:19:13 UTC
I think the safest method to achieve this is to add option to switch to Maintenance mode when admin execute power management restart on a host. This way we can be sure, that host resources were cleared (we can't be sure about it for SSH restart).

Comment 2 Martin Perina 2019-08-23 08:28:21 UTC
*** Bug 1670329 has been marked as a duplicate of this bug. ***

Comment 3 Petr Matyáš 2020-01-24 11:25:20 UTC
The host can't be switched to Maintenance from Unassigned state, either change the summary or create a fix so it is really all situations.

Tested on ovirt-engine-4.4.0-0.14.master.el7.noarch

Comment 4 Martin Perina 2020-01-24 12:43:15 UTC
Unassigned status is hidden status and it should always be a temporary short term status. This means that engine itself should move a host from Unassgined status to some other valid status automatically. If the host stays in Unassigned status for longer time (let's say a minute or more), then please file a bug, because there is no way how administrators could handle host in Unassigned status.

Comment 5 Petr Matyáš 2020-02-10 14:45:17 UTC
Verified on ovirt-engine-4.4.0-0.19.master.el7.noarch

Comment 6 Sandro Bonazzola 2020-05-20 20:00:53 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.