Bug 1574463 - RHEV-M UI shows bricks in down state though it is online
Summary: RHEV-M UI shows bricks in down state though it is online
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.5
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1574464
Blocks: 1520836
TreeView+ depends on / blocked
 
Reported: 2018-05-03 11:27 UTC by bipin
Modified: 2018-11-08 05:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1574464 (view as bug list)
Environment:
Last Closed: 2018-11-08 05:39:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3523 0 None None None 2018-11-08 05:39:53 UTC

Description bipin 2018-05-03 11:27:27 UTC
Description of problem:
After the HE deployment, in one of the host all the bricks are shown as down. But this isn't the actual case since the bricks are online during gluster volume show. Have attached the UI screenshot

Version-Release number of selected component (if applicable):
redhat-release-virtualization-host-4.2-3.0.el7.x86_64
glusterfs-3.12.2-8.el7rhgs.x86_64

How reproducible:


Steps to Reproduce:
1.Complete HE deployment
2.Put the host to maintenance and later activate it
3.See the bricks down in UI

Actual results:
The bricks are showing up as down state

Expected results:
The bricks should return show online

Additional info:

Gluster volume status:

[root@rhsqa-grafton7-nic2 glusterfs]# gluster volume status
Status of volume: VDO_Test
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.45.29:/gluster_bricks/VDO_Test/
VDO_Test                                    49152     0          Y       3746 
Brick 10.70.45.30:/gluster_bricks/VDO_Test/
VDO_Test                                    49152     0          Y       3756 
Brick 10.70.45.31:/gluster_bricks/VDO_Test/
VDO_Test                                    49156     0          Y       48079
Self-heal Daemon on localhost               N/A       N/A        Y       5044 
Self-heal Daemon on rhsqa-grafton9.lab.eng.
blr.redhat.com                              N/A       N/A        Y       52138
Self-heal Daemon on 10.70.45.30             N/A       N/A        Y       32637
 
Task Status of Volume VDO_Test
------------------------------------------------------------------------------
There are no active volume tasks
 
Status of volume: data
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.45.29:/gluster_bricks/data/data 49156     0          Y       5034 
Brick 10.70.45.30:/gluster_bricks/data/data 49153     0          Y       27158
Brick 10.70.45.31:/gluster_bricks/data/data 49157     0          Y       48309
Self-heal Daemon on localhost               N/A       N/A        Y       5044 
Self-heal Daemon on rhsqa-grafton9.lab.eng.
blr.redhat.com                              N/A       N/A        Y       52138
Self-heal Daemon on 10.70.45.30             N/A       N/A        Y       32637
 
Task Status of Volume data
------------------------------------------------------------------------------
There are no active volume tasks
 
Status of volume: engine
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.45.29:/gluster_bricks/engine/en
gine                                        49155     0          Y       31307
Brick 10.70.45.30:/gluster_bricks/engine/en
gine                                        49155     0          Y       29459
Brick 10.70.45.31:/gluster_bricks/engine/en
gine                                        49152     0          Y       48597
Self-heal Daemon on localhost               N/A       N/A        Y       5044 
Self-heal Daemon on 10.70.45.30             N/A       N/A        Y       32637
Self-heal Daemon on rhsqa-grafton9.lab.eng.
blr.redhat.com                              N/A       N/A        Y       52138
 
Task Status of Volume engine
------------------------------------------------------------------------------
There are no active volume tasks
 
Status of volume: vmstore
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick 10.70.45.29:/gluster_bricks/vmstore/v
mstore                                      49154     0          Y       31146
Brick 10.70.45.30:/gluster_bricks/vmstore/v
mstore                                      49154     0          Y       29393
Brick 10.70.45.31:/gluster_bricks/vmstore/v
mstore                                      49158     0          Y       48567
Self-heal Daemon on localhost               N/A       N/A        Y       5044 
Self-heal Daemon on rhsqa-grafton9.lab.eng.
blr.redhat.com                              N/A       N/A        Y       52138
Self-heal Daemon on 10.70.45.30             N/A       N/A        Y       32637
 
Task Status of Volume vmstore
------------------------------------------------------------------------------
There are no active volume tasks

Comment 5 bipin 2018-06-05 04:50:39 UTC
Tested this on the version vdsm-4.20.29-1.el7ev.x86_64. Moving it to verified.

Comment 7 errata-xmlrpc 2018-11-08 05:39:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3523


Note You need to log in before you can comment on or make changes to this bug.