Bug 1574480 - vGPU: Webadmin should reject VM snapshot creation when using mdev_type hook.
Summary: vGPU: Webadmin should reject VM snapshot creation when using mdev_type hook.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Shmuel Melamud
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 12:02 UTC by Nisim Simsolo
Modified: 2018-06-26 08:45 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:45:22 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
vdsm.log (4.15 MB, text/plain)
2018-05-03 12:04 UTC, Nisim Simsolo
no flags Details
engine.log (5.48 MB, text/plain)
2018-05-03 12:05 UTC, Nisim Simsolo
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91188 0 master MERGED engine: Reject CreateSnapshot when using mdev_type hook 2018-05-13 15:49:23 UTC
oVirt gerrit 91435 0 ovirt-engine-4.2 MERGED engine: Reject CreateSnapshot when using mdev_type hook 2018-05-22 09:15:18 UTC

Description Nisim Simsolo 2018-05-03 12:02:33 UTC
Description of problem:
Webadmin should reject snapshot creation when using mdev_hook on VM, which is the current behavior of Webadmin when trying to create snapshot of VM with non-usb passthrough of host device.

- Trying to create VM snapshot when using mdev_type hook failed with the next vdsm.log - libvirtError: 
Requested operation is not valid: domain has assigned non-USB host devices

- When using VFIO for example, The Webadmin rejects snapshot creation with the next operation canceled message:
Error while executing action:
1_VFIO_f23_Intel:
    Cannot create Snapshot. VM has PCI host devices attached.


Version-Release number of selected component (if applicable):
rhvm-4.2.3.3-0.1.el7
vdsm-4.20.27-1.el7ev.x86_64
libvirt-client-3.9.0-14.el7_5.2.x86_64
sanlock-3.6.0-1.el7.x86_64
qemu-kvm-rhev-2.10.0-21.el7_5.2.x86_64
NVIDIA-Linux-x86_64-390.21

How reproducible:
100%

Steps to Reproduce:
1. Run VM with mdev_type hook
2. Try to create snapshot
3.

Actual results:
Snapshot creation failed.

Expected results:
Behavior should be aligned with host device passthrough devices which is rejection snapshot creation with an appropriate message.

Additional info:
vdsm.log (see 2018-05-03 14:46:39,754+0300 ERROR) and engine.log attached.

Comment 1 Nisim Simsolo 2018-05-03 12:04:55 UTC
Created attachment 1430628 [details]
vdsm.log

Comment 2 Nisim Simsolo 2018-05-03 12:05:56 UTC
Created attachment 1430629 [details]
engine.log

Comment 3 meital avital 2018-05-31 07:40:30 UTC
Verification verision:
rhvm-4.2.4-0.1.el7
libvirt-client-3.9.0-14.el7_5.5.x86_64
qemu-kvm-rhev-2.10.0-21.el7_5.3.x86_64
vdsm-4.20.28-1.el7ev.x86_64
vdsm-hook-vfio-mdev-4.20.28-1.el7ev

Verification steps:
1. Run VM with mdev_type hook
2. Try to create VM snapshot
Webadmin rejects action with the next pop-up message:
"Error while executing action:

vGPU_Win10-source:
Cannot create Snapshot. VM uses mdev_type hook."

Comment 4 Sandro Bonazzola 2018-06-26 08:45:22 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.