Bug 1574481 - Power 9 host should report host capability to support Power 8 VMs with Power 8 hosts in the same cluster
Summary: Power 9 host should report host capability to support Power 8 VMs with Power ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: ---
Hardware: ppc64le
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.2.5
: ---
Assignee: Dan Kenigsberg
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1574494
TreeView+ depends on / blocked
 
Reported: 2018-05-03 12:07 UTC by Michal Skrivanek
Modified: 2018-07-31 15:31 UTC (History)
2 users (show)

Fixed In Version: vdsm-4.20.28-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 15:31:19 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 91215 ovirt-4.2 MERGED machinetype: compare POWER CPUs compat modes 2018-05-17 11:29:50 UTC

Description Michal Skrivanek 2018-05-03 12:07:57 UTC
On x86 this is done by reporting all the "previous" CPUs in VDMS caps. Power currently reports only Power9 so it can't be added to a Power8 cluster. VMs should run in Power8 compatibility mode on a Power9 in a Power8 cluster

Comment 1 Martin Polednik 2018-05-03 12:45:09 UTC
This does seem to be caused by libvirt's CPU comparision call (libvirtconnection.compareCPU) - more specifically, we check that the model is 

libvirt.VIR_CPU_COMPARE_SUPERSET or
libvirt.VIR_CPU_COMPARE_IDENTICAL.

Is this a specific PVR/CPU model that happens to be incompatible w/ POWER8 or a bug in libvirt? oVirt has switched to the compat=power8 cpu mode that should guarantee at least *some* level of POWER8/POWER9 compat.

Comment 2 Andrea Bolognani 2018-05-04 12:46:09 UTC
(In reply to Martin Polednik from comment #1)
> This does seem to be caused by libvirt's CPU comparision call
> (libvirtconnection.compareCPU) - more specifically, we check that the model
> is 
> 
> libvirt.VIR_CPU_COMPARE_SUPERSET or
> libvirt.VIR_CPU_COMPARE_IDENTICAL.
> 
> Is this a specific PVR/CPU model that happens to be incompatible w/ POWER8
> or a bug in libvirt? oVirt has switched to the compat=power8 cpu mode that
> should guarantee at least *some* level of POWER8/POWER9 compat.

It seems to work fine here:

  $ virsh capabilities | grep POWER
      <model>POWER9</model>

  $ cat cpu.xml
  <cpu mode='host-model'>
    <model>power8</model>
  </cpu>

  $ virsh cpu-compare cpu.xml
  CPU described in cpu.xml is identical to host CPU

The support was introduce quite a while ago:

  commit 5c8c2d1633f3d2500e49132296793fc267648d2b
  Author: Jiri Denemark <jdenemar@redhat.com>
  Date:   Wed May 17 16:39:16 2017 +0200

      cpu_ppc64: Add support for host-model on POWER9

      Signed-off-by: Jiri Denemark <jdenemar@redhat.com>

  v3.4.0-95-g5c8c2d1633

Can you try the steps above on your machine and share the results?

Comment 3 Sandro Bonazzola 2018-06-29 15:13:10 UTC
Can be tested with 4.2.4 release since it should have been fixed in vdsm v4.20.28

Comment 5 Israel Pinto 2018-07-03 10:31:22 UTC
Verify with:
vdsm-4.20.32-1.el7ev.ppc64le

Steps:
Run VM on Power9 host in Power8 cluster.

Results:
VM is up and running

VM xml
virsh -r dumpxml 1 | grep power8 
  <cpu mode='host-model' check='partial'>
    <model fallback='forbid'>power8</model>

Host info:
# virsh -r capabilities | grep POWER
      <model>POWER9</model>


PASS

Comment 6 Sandro Bonazzola 2018-07-31 15:31:19 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.