Bug 1574492 - Update spacewalk-remote-utils with RHEL 7.5 channel definitions
Summary: Update spacewalk-remote-utils with RHEL 7.5 channel definitions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiří Dostál
QA Contact: Radovan Drazny
URL:
Whiteboard:
: 1597630 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 12:24 UTC by Jiří Dostál
Modified: 2018-07-30 15:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 15:13:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2287 None None None 2018-07-30 15:13:17 UTC

Description Jiří Dostál 2018-05-03 12:24:50 UTC
Description of problem:
/usr/share/rhn/channel-data/ doesn't have RHEL 7.5 files

Version-Release number of selected component (if applicable):
spacewalk-remote-utils-2.5.1-10

How reproducible:
Always

Actual results:
Error: data files for RHEL 7.5 do not exist

Expected results:
Data files should be there and channel should be created

Comment 1 Jiří Dostál 2018-05-03 12:32:34 UTC
spacewalk 777b23af6055736f179e00e99a49589b0343ca66

Comment 2 Tomáš Kašpárek 2018-07-03 10:44:24 UTC
*** Bug 1597630 has been marked as a duplicate of this bug. ***

Comment 4 Radovan Drazny 2018-07-24 15:12:14 UTC
What is the reason for two empty files in the channel data in RHEL 7 build of spacewalk-remote-utils?

$ ls -l /usr/share/rhn/channel-data/6-u10*Workstation
-rw-r--r--. 1 root root 0 Jul 20 11:34 /usr/share/rhn/channel-data/6-u10-workstation-i386-Workstation
-rw-r--r--. 1 root root 0 Jul 20 11:34 /usr/share/rhn/channel-data/6-u10-workstation-x86_64-Workstation

These two files are not present in RHEL5 nor RHEL6 builds.

Comment 5 Jiří Dostál 2018-07-25 08:19:37 UTC
6.10 Channel definitions were provided by bz1596250, thus clearing needinfo on myself.

Comment 7 Radovan Drazny 2018-07-25 14:25:06 UTC
Verified on spacewalk-remote-utils-2.5.1-12

RHEL5
$ for item in /usr/share/rhn/channel-data/7-u5*;do wc -l ${item}; done
4227 /usr/share/rhn/channel-data/7-u5-client-x86_64
5158 /usr/share/rhn/channel-data/7-u5-client-x86_64-Optional
17 /usr/share/rhn/channel-data/7-u5-client-x86_64-Supplementary
2807 /usr/share/rhn/channel-data/7-u5-computenode-x86_64
5243 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Optional
12 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Supplementary
4435 /usr/share/rhn/channel-data/7-u5-server-ppc64
4383 /usr/share/rhn/channel-data/7-u5-server-ppc64-Optional
20 /usr/share/rhn/channel-data/7-u5-server-ppc64-Supplementary
4321 /usr/share/rhn/channel-data/7-u5-server-s390x
31 /usr/share/rhn/channel-data/7-u5-server-s390x-Highavailability
4374 /usr/share/rhn/channel-data/7-u5-server-s390x-Optional
36 /usr/share/rhn/channel-data/7-u5-server-s390x-Resilientstorage
18 /usr/share/rhn/channel-data/7-u5-server-s390x-Supplementary
5099 /usr/share/rhn/channel-data/7-u5-server-x86_64
47 /usr/share/rhn/channel-data/7-u5-server-x86_64-Highavailability
4750 /usr/share/rhn/channel-data/7-u5-server-x86_64-Optional
52 /usr/share/rhn/channel-data/7-u5-server-x86_64-Resilientstorage
17 /usr/share/rhn/channel-data/7-u5-server-x86_64-Supplementary
5307 /usr/share/rhn/channel-data/7-u5-workstation-x86_64
4540 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Optional
17 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Supplementary

RHEL6
$ for item in /usr/share/rhn/channel-data/7-u5*;do wc -l ${item}; done
4227 /usr/share/rhn/channel-data/7-u5-client-x86_64                                                                                                                                                                                         
5158 /usr/share/rhn/channel-data/7-u5-client-x86_64-Optional                                                                                                                                                                                
17 /usr/share/rhn/channel-data/7-u5-client-x86_64-Supplementary                                                                                                                                                                             
2807 /usr/share/rhn/channel-data/7-u5-computenode-x86_64                                                                                                                                                                                    
5243 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Optional                                                                                                                                                                           
12 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Supplementary                                                                                                                                                                        
4435 /usr/share/rhn/channel-data/7-u5-server-ppc64                                                                                                                                                                                          
4383 /usr/share/rhn/channel-data/7-u5-server-ppc64-Optional                                                                                                                                                                                 
20 /usr/share/rhn/channel-data/7-u5-server-ppc64-Supplementary                                                                                                                                                                              
4321 /usr/share/rhn/channel-data/7-u5-server-s390x                                                                                                                                                                                          
31 /usr/share/rhn/channel-data/7-u5-server-s390x-Highavailability                                                                                                                                                                           
4374 /usr/share/rhn/channel-data/7-u5-server-s390x-Optional                                                                                                                                                                                 
36 /usr/share/rhn/channel-data/7-u5-server-s390x-Resilientstorage                                                                                                                                                                           
18 /usr/share/rhn/channel-data/7-u5-server-s390x-Supplementary                                                                                                                                                                              
5099 /usr/share/rhn/channel-data/7-u5-server-x86_64                                                                                                                                                                                         
47 /usr/share/rhn/channel-data/7-u5-server-x86_64-Highavailability                                                                                                                                                                          
4750 /usr/share/rhn/channel-data/7-u5-server-x86_64-Optional                                                                                                                                                                                
52 /usr/share/rhn/channel-data/7-u5-server-x86_64-Resilientstorage                                                                                                                                                                          
17 /usr/share/rhn/channel-data/7-u5-server-x86_64-Supplementary                                                                                                                                                                             
5307 /usr/share/rhn/channel-data/7-u5-workstation-x86_64                                                                                                                                                                                    
4540 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Optional                                                                                                                                                                           
17 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Supplementary

RHEL7
$ for item in /usr/share/rhn/channel-data/7-u5*;do wc -l ${item}; done
4227 /usr/share/rhn/channel-data/7-u5-client-x86_64                                                                                                                                                                                         
5158 /usr/share/rhn/channel-data/7-u5-client-x86_64-Optional                                                                                                                                                                                
17 /usr/share/rhn/channel-data/7-u5-client-x86_64-Supplementary                                                                                                                                                                             
2807 /usr/share/rhn/channel-data/7-u5-computenode-x86_64                                                                                                                                                                                    
5243 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Optional                                                                                                                                                                           
12 /usr/share/rhn/channel-data/7-u5-computenode-x86_64-Supplementary                                                                                                                                                                        
4435 /usr/share/rhn/channel-data/7-u5-server-ppc64                                                                                                                                                                                          
4383 /usr/share/rhn/channel-data/7-u5-server-ppc64-Optional                                                                                                                                                                                 
20 /usr/share/rhn/channel-data/7-u5-server-ppc64-Supplementary                                                                                                                                                                              
4321 /usr/share/rhn/channel-data/7-u5-server-s390x                                                                                                                                                                                          
31 /usr/share/rhn/channel-data/7-u5-server-s390x-Highavailability                                                                                                                                                                           
4374 /usr/share/rhn/channel-data/7-u5-server-s390x-Optional                                                                                                                                                                                 
36 /usr/share/rhn/channel-data/7-u5-server-s390x-Resilientstorage                                                                                                                                                                           
18 /usr/share/rhn/channel-data/7-u5-server-s390x-Supplementary                                                                                                                                                                              
5099 /usr/share/rhn/channel-data/7-u5-server-x86_64                                                                                                                                                                                         
47 /usr/share/rhn/channel-data/7-u5-server-x86_64-Highavailability                                                                                                                                                                          
4750 /usr/share/rhn/channel-data/7-u5-server-x86_64-Optional                                                                                                                                                                                
52 /usr/share/rhn/channel-data/7-u5-server-x86_64-Resilientstorage                                                                                                                                                                          
17 /usr/share/rhn/channel-data/7-u5-server-x86_64-Supplementary                                                                                                                                                                             
5307 /usr/share/rhn/channel-data/7-u5-workstation-x86_64                                                                                                                                                                                    
4540 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Optional                                                                                                                                                                           
17 /usr/share/rhn/channel-data/7-u5-workstation-x86_64-Supplementary

Comment 12 errata-xmlrpc 2018-07-30 15:13:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2287


Note You need to log in before you can comment on or make changes to this bug.