Bug 1574500 - test_preventing_firewall_blink fails
Summary: test_preventing_firewall_blink fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Slawek Kaplonski
QA Contact: Toni Freger
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 12:35 UTC by Arie Bregman
Modified: 2018-06-27 13:56 UTC (History)
6 users (show)

Fixed In Version: openstack-neutron-12.0.2-0.20180421011359.0ec54fd.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1708731 0 None None None 2018-05-14 11:39:43 UTC
OpenStack gerrit 563990 0 None None None 2018-05-14 11:38:44 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:56:49 UTC

Description Arie Bregman 2018-05-03 12:35:46 UTC
Description of problem:

The following functional test fails sometimes:

neutron.tests.functional.agent.test_firewall.FirewallTestCase.test_preventing_firewall_blink(OVS Firewall Driver,native)

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "neutron/tests/base.py", line 132, in func
        return f(self, *args, **kwargs)
      File "neutron/tests/functional/agent/test_firewall.py", line 575, in test_preventing_firewall_blink
        self.assertEqual(packets_received, 0)
      File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 350, in assertEqual
        self.assertThat(observed, matcher, message)
      File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 435, in assertThat
        raise mismatch_error
    testtools.matchers._impl.MismatchError: 1 != 0
    


Version-Release number of selected component (if applicable): Latest OSP 13


How reproducible: 50%


Steps to Reproduce:
1. Clone neutron
2. Checkout OSP 13 branch
3. Run dsvm-functional test env

Comment 10 errata-xmlrpc 2018-06-27 13:55:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.