Bug 1574519 - Nginx does not start on a new Fedora 28 server installation
Summary: Nginx does not start on a new Fedora 28 server installation
Keywords:
Status: CLOSED DUPLICATE of bug 1573942
Alias: None
Product: Fedora
Classification: Fedora
Component: nginx
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 13:02 UTC by Dylan Taylor
Modified: 2020-11-05 09:31 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 13:31:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Dylan Taylor 2018-05-03 13:02:25 UTC
Description of problem:

Nginx X does not start with default configuration on 28 Server.

Version-Release number of selected component (if applicable):
# rpm -qa | grep nginx
nginx-filesystem-1.12.1-5.fc28.noarch
nginx-1.12.1-5.fc28.x86_64
nginx-mimetypes-2.1.48-3.fc28.noarch


How reproducible:

100% on a new installation. I tried installing on 27 then upgrading and it worked just fine.

Steps to Reproduce:
1. Install Nginx package on fresh install (mine is in a KVM VM with 2GB RAM, 10 GB disk, probably doesn't matter)
2. sudo systemctl enable nginx
3. sudo systemctl start nginx


Actual results:

Nginx does not start.

[root@myserver ~]# systemctl enable nginx
[root@myserver ~]# systemctl start nginx
[root@myserver ~]# systemctl status nginx
● nginx.service - The nginx HTTP and reverse proxy server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/nginx.service.d
           └─php-fpm.conf
   Active: failed (Result: exit-code) since Thu 2018-05-03 05:56:15 PDT; 5s ago

May 03 05:56:15 myserver.test systemd[1]: Starting The nginx HTTP and reverse proxy server...
May 03 05:56:15 myserver.test nginx[7610]: nginx: [alert] could not open error log file: open() "/var/log/nginx/error.log" failed (13: Permission denied)
May 03 05:56:15 myserver.test nginx[7610]: 2018/05/03 05:56:15 [warn] 7610#0: could not build optimal types_hash, you should increase either types_hash_max_size: 1024 or types_hash_bucket_size: 64; ignor>
May 03 05:56:15 myserver.test nginx[7610]: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
May 03 05:56:15 myserver.test nginx[7610]: 2018/05/03 05:56:15 [emerg] 7610#0: mkdir() "/var/lib/nginx/tmp/client_body" failed (13: Permission denied)
May 03 05:56:15 myserver.test nginx[7610]: nginx: configuration file /etc/nginx/nginx.conf test failed
May 03 05:56:15 myserver.test systemd[1]: nginx.service: Control process exited, code=exited status=1
May 03 05:56:15 myserver.test systemd[1]: nginx.service: Failed with result 'exit-code'.
May 03 05:56:15 myserver.test systemd[1]: Failed to start The nginx HTTP and reverse proxy server.


Expected results:

Nginx is started and an example web server is accessible on port 80, at least via localhost until the firewall rules are changed.

Additional info:

Comment 1 Luboš Uhliarik 2018-05-03 13:31:16 UTC

*** This bug has been marked as a duplicate of bug 1573942 ***


Note You need to log in before you can comment on or make changes to this bug.