Bug 1574547 - plplot: FTBFS in Fedora rawhide
Summary: plplot: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: plplot
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
: 1605480 (view as bug list)
Depends On:
Blocks: F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-05-03 14:20 UTC by Jitka Plesnikova
Modified: 2018-07-24 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-24 22:16:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Jitka Plesnikova 2018-05-03 14:20:43 UTC
Description of problem:
Package plplot fails to build from source in Fedora rawhide with following error:

+ /usr/bin/cmake -DCMAKE_C_FLAGS_RELEASE:STRING=-DNDEBUG 
<...>
-- The C compiler identification is GNU 8.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- broken
CMake Error at /usr/share/cmake/Modules/CMakeTestCCompiler.cmake:52 (message):
  The C compiler
    "/usr/bin/cc"
  is not able to compile a simple test program.
  It fails with the following output:
    Change Dir: /builddir/build/BUILD/plplot-5.12.0/fedora/CMakeFiles/CMakeTmp
    
    Run Build Command:"/usr/bin/gmake" "cmTC_01fbf/fast"
    /usr/bin/gmake -f CMakeFiles/cmTC_01fbf.dir/build.make CMakeFiles/cmTC_01fbf.dir/build
    gmake[1]: Entering directory '/builddir/build/BUILD/plplot-5.12.0/fedora/CMakeFiles/CMakeTmp'
    Building C object CMakeFiles/cmTC_01fbf.dir/testCCompiler.c.o
    /usr/bin/cc   -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection    -o CMakeFiles/cmTC_01fbf.dir/testCCompiler.c.o   -c /builddir/build/BUILD/plplot-5.12.0/fedora/CMakeFiles/CMakeTmp/testCCompiler.c
    annobin: testCCompiler.c: Error: plugin built for compiler version (8.1.1) but run with compiler version (8.0.1)
    cc1: error: fail to initialize plugin /usr/lib/gcc/x86_64-redhat-linux/8/plugin/annobin.so
    gmake[1]: *** [CMakeFiles/cmTC_01fbf.dir/build.make:66: CMakeFiles/cmTC_01fbf.dir/testCCompiler.c.o] Error 1
    gmake[1]: Leaving directory '/builddir/build/BUILD/plplot-5.12.0/fedora/CMakeFiles/CMakeTmp'
    gmake: *** [Makefile:126: cmTC_01fbf/fast] Error 2


Version-Release number of selected component (if applicable):
5.12.0-10.fc29

Steps to Reproduce:
koji build --scratch f29 plplot-5.12.0-10.fc29.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/plplot

Dependency changes from the last successful build can be found here:
https://apps.fedoraproject.org/koschei/build/4692252

Comment 1 Orion Poplawski 2018-07-22 16:16:17 UTC
*** Bug 1605480 has been marked as a duplicate of this bug. ***

Comment 2 Igor Raits 2018-07-24 22:16:36 UTC
There has been at least one successfull build after this bug got created.

plplot-5.13.0-1.fc29: https://koji.fedoraproject.org/koji/buildinfo?buildID=1130033


Note You need to log in before you can comment on or make changes to this bug.