Bug 1574550 - [abrt] cinnamon: basename(): posixpath.py:146:basename:TypeError: expected str, bytes or os.PathLike object, not AutostartApp
Summary: [abrt] cinnamon: basename(): posixpath.py:146:basename:TypeError: expected st...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f0a73a1566eee2c2177d52188b2...
: 1575147 1575338 1577834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 14:22 UTC by Jan Niklas Hasse
Modified: 2018-10-01 02:46 UTC (History)
3 users (show)

Fixed In Version: cinnamon-3.8.9-1.fc29 cinnamon-3.8.9-1.fc27 cinnamon-3.8.9-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-30 23:26:14 UTC


Attachments (Terms of Use)
File: backtrace (642 bytes, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: cgroup (331 bytes, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: cpuinfo (1.63 KB, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: environ (1.30 KB, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: mountinfo (3.42 KB, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: namespaces (129 bytes, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details
File: open_fds (1.66 KB, text/plain)
2018-05-03 14:22 UTC, Jan Niklas Hasse
no flags Details

Description Jan Niklas Hasse 2018-05-03 14:22:21 UTC
Description of problem:
Tried to add a custom start command

Version-Release number of selected component:
cinnamon-3.8.0-2.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py startup
crash_function: basename
exception_type: TypeError
executable:     /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.5-300.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
posixpath.py:146:basename:TypeError: expected str, bytes or os.PathLike object, not AutostartApp

Traceback (most recent call last):
  File "/usr/share/cinnamon/cinnamon-settings/modules/cs_startup.py", line 545, in on_add_custom
    key = get_appname(app)
  File "/usr/share/cinnamon/cinnamon-settings/modules/cs_startup.py", line 31, in get_appname
    basename = os.path.basename(filename)
  File "/usr/lib64/python3.6/posixpath.py", line 146, in basename
    p = os.fspath(p)
TypeError: expected str, bytes or os.PathLike object, not AutostartApp

Local variables in innermost frame:
p: <cs_startup.AutostartApp object at 0x7f22ce4f4278>

Comment 1 Jan Niklas Hasse 2018-05-03 14:22:25 UTC
Created attachment 1430735 [details]
File: backtrace

Comment 2 Jan Niklas Hasse 2018-05-03 14:22:26 UTC
Created attachment 1430736 [details]
File: cgroup

Comment 3 Jan Niklas Hasse 2018-05-03 14:22:28 UTC
Created attachment 1430737 [details]
File: cpuinfo

Comment 4 Jan Niklas Hasse 2018-05-03 14:22:30 UTC
Created attachment 1430738 [details]
File: environ

Comment 5 Jan Niklas Hasse 2018-05-03 14:22:33 UTC
Created attachment 1430739 [details]
File: mountinfo

Comment 6 Jan Niklas Hasse 2018-05-03 14:22:34 UTC
Created attachment 1430740 [details]
File: namespaces

Comment 7 Jan Niklas Hasse 2018-05-03 14:22:35 UTC
Created attachment 1430741 [details]
File: open_fds

Comment 8 leigh scott 2018-05-03 16:35:19 UTC
Fixed upstream

https://github.com/linuxmint/Cinnamon/issues/7539

Comment 9 zethan191 2018-05-04 21:26:06 UTC
*** Bug 1575147 has been marked as a duplicate of this bug. ***

Comment 10 zethan191 2018-05-06 05:20:08 UTC
*** Bug 1575338 has been marked as a duplicate of this bug. ***

Comment 11 polyser3 2018-05-14 08:43:07 UTC
*** Bug 1577834 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2018-09-21 18:37:42 UTC
cinnamon-3.8.9-1.fc29 cinnamon-control-center-3.8.2-1.fc29 cinnamon-settings-daemon-3.8.6-1.fc29 muffin-3.8.3-1.fc29 nemo-3.8.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-248024aacb

Comment 13 Fedora Update System 2018-09-21 18:38:10 UTC
cinnamon-3.8.9-1.fc27 cinnamon-control-center-3.8.2-1.fc27 cinnamon-settings-daemon-3.8.6-1.fc27 muffin-3.8.3-1.fc27 nemo-3.8.6-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b1954e7d77

Comment 14 Fedora Update System 2018-09-21 18:38:36 UTC
cinnamon-3.8.9-1.fc28 cinnamon-control-center-3.8.2-1.fc28 cinnamon-settings-daemon-3.8.6-1.fc28 muffin-3.8.3-1.fc28 nemo-3.8.6-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9f75cb1224

Comment 15 Fedora Update System 2018-09-22 20:05:24 UTC
cinnamon-3.8.9-1.fc29, cinnamon-control-center-3.8.2-1.fc29, cinnamon-settings-daemon-3.8.6-1.fc29, muffin-3.8.3-1.fc29, nemo-3.8.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-248024aacb

Comment 16 Fedora Update System 2018-09-22 20:41:48 UTC
cinnamon-3.8.9-1.fc27, cinnamon-control-center-3.8.2-1.fc27, cinnamon-settings-daemon-3.8.6-1.fc27, muffin-3.8.3-1.fc27, nemo-3.8.6-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b1954e7d77

Comment 17 Fedora Update System 2018-09-22 22:14:03 UTC
cinnamon-3.8.9-1.fc28, cinnamon-control-center-3.8.2-1.fc28, cinnamon-settings-daemon-3.8.6-1.fc28, muffin-3.8.3-1.fc28, nemo-3.8.6-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9f75cb1224

Comment 18 Fedora Update System 2018-09-30 23:26:14 UTC
cinnamon-3.8.9-1.fc29, cinnamon-control-center-3.8.2-1.fc29, cinnamon-settings-daemon-3.8.6-1.fc29, muffin-3.8.3-1.fc29, nemo-3.8.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-10-01 01:22:23 UTC
cinnamon-3.8.9-1.fc27, cinnamon-control-center-3.8.2-1.fc27, cinnamon-settings-daemon-3.8.6-1.fc27, muffin-3.8.3-1.fc27, nemo-3.8.6-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-10-01 02:46:49 UTC
cinnamon-3.8.9-1.fc28, cinnamon-control-center-3.8.2-1.fc28, cinnamon-settings-daemon-3.8.6-1.fc28, muffin-3.8.3-1.fc28, nemo-3.8.6-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.