Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574591 - [RHEL-6] Include updated AMD firmware for Spectre mitigation
Summary: [RHEL-6] Include updated AMD firmware for Spectre mitigation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl
Version: 6.10
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Petr Oros
QA Contact: Rachel Sibley
URL:
Whiteboard:
: 1564518 (view as bug list)
Depends On: 1564518
Blocks: 1425546 1566479 1576313 1576314 1576315 1576316 1576317
TreeView+ depends on / blocked
 
Reported: 2018-05-03 15:31 UTC by Stanislav Kozina
Modified: 2018-06-19 05:17 UTC (History)
12 users (show)

Fixed In Version: microcode_ctl-1.17-32.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576313 1576314 1576315 1576316 1576317 (view as bug list)
Environment:
Last Closed: 2018-06-19 05:16:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1887 0 None None None 2018-06-19 05:17:43 UTC

Description Stanislav Kozina 2018-05-03 15:31:59 UTC
Please include AMD microcode for Spectre mitigation.

Comment 10 Rachel Sibley 2018-05-23 15:39:31 UTC
ALL TESTS PASSED

Comparing the official brew build with the previous scratch build, the only difference I see is the time stamp changes, with testing from  https://bugzilla.redhat.com/show_bug.cgi?id=1574591#c8, we can move this to verified now.

$ rpmdiff /mnt/redhat/brewroot/scratch/poros/task_16379211/microcode_ctl-1.17-32.el6.x86_64.rpm /mnt/redhat/brewroot/packages/microcode_ctl/1.17/32.el6/x86_64/microcode_ctl-1.17-32.el6.x86_64.rpm
    ..........T /lib/firmware/amd-ucode
    ..........T /lib/firmware/amd-ucode/microcode_amd.bin
    ..........T /lib/firmware/amd-ucode/microcode_amd.bin.asc
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam15h.bin
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam15h.bin.asc
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam16h.bin
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam16h.bin.asc
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam17h.bin
    ..........T /lib/firmware/amd-ucode/microcode_amd_fam17h.bin.asc
    ..........T /lib/firmware/microcode.dat
    ..........T /lib/udev/rules.d/89-microcode.rules
    ..........T /sbin/microcode_ctl
    ..........T /usr/share/doc/microcode_ctl/disclaimer
    ..........T /usr/share/man/man8/microcode_ctl.8.gz

Comment 12 Stanislav Kozina 2018-06-07 08:26:19 UTC
*** Bug 1564518 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2018-06-19 05:16:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1887


Note You need to log in before you can comment on or make changes to this bug.