Bug 1574637 - opensmtpd: Dependency on libevent 2.0 prevents installation
Summary: opensmtpd: Dependency on libevent 2.0 prevents installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: opensmtpd
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Denis Fateyev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 18:16 UTC by Dirk Dankhoff
Modified: 2018-05-15 20:05 UTC (History)
2 users (show)

Fixed In Version: opensmtpd-6.0.3p1-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 20:05:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Dirk Dankhoff 2018-05-03 18:16:14 UTC
Description of problem:
When trying to upgrade from Fedora 27 to 28 dnf system-upgrade fails because of an unresolved dependency on libevent 2.0. The Fedora 28 repos seem to only provide libevent 2.1 at the moment which does not match opensmtpd-6.0.3p1-2.fc28.x86_64's Requires stanza (libevent-2.0.so.5()(64bit)).
This situation probably also prevents the package from being installed on a F28 system in the first place (untested).

The opensmtpd package should probably be rebuilt against libevent-2.1 or an additional package providing libevent-2.0.so.5()(64bit) should be in the repositories.

Version-Release number of selected component (if applicable):
opensmtpd-6.0.3p1-2.fc28.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a up-to-date Fedora 27 with opensmtpd-6.0.3p1-1.fc27.x86_64 installed
2. Try to do a system-upgrade via `dnf system-upgrade download --releasever=28`

Actual results:
dnf fails to upgrade opensmtpd and thus the release version with:

```
 Problem: problem with installed package opensmtpd-6.0.3p1-1.fc27.x86_64
  - package opensmtpd-6.0.3p1-2.fc28.x86_64 requires libevent-2.0.so.5()(64bit), but none of the providers can be installed
  - opensmtpd-6.0.3p1-1.fc27.x86_64 does not belong to a distupgrade repository
  - libevent-2.0.22-6.fc27.x86_64 does not belong to a distupgrade repository
```

Expected results:
opensmtpd and therefor the system's release version are correctly upgraded.

Additional info:
Judging by the info on Koji (https://koji.fedoraproject.org/koji/packageinfo?packageID=761) the version of libevent was bumped after the F28 mass rebuild (rebuilt on 2018-02-09; bumped to 2.1 on 2018-02-14). So this issue could potentially impact more dependent packages.

Comment 1 Christian Lask 2018-05-04 15:39:19 UTC
I can confirm this bug. 

On an upgraded F28 (with --allowerasing due to the above described problem), the installation of OpenSMTPD fails due to the same missing dependency:

```
sudo dnf install opensmtpd
Last metadata expiration check: 0:19:29 ago on Fri 04 May 2018 17:18:06 CEST.
Error:
 Problem: conflicting requests
  - nothing provides libevent-2.0.so.5()(64bit) needed by opensmtpd-6.0.3p1-2.fc28.x86_64
```

Comment 2 Fedora Update System 2018-05-05 20:37:38 UTC
opensmtpd-6.0.3p1-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0f054e9308

Comment 3 Fedora Update System 2018-05-07 10:47:27 UTC
opensmtpd-6.0.3p1-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0f054e9308

Comment 4 Fedora Update System 2018-05-15 20:05:35 UTC
opensmtpd-6.0.3p1-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.