Bug 1574639 - SSO not working in 4.2
Summary: SSO not working in 4.2
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: ovirt-guest-agent
Classification: oVirt
Component: General
Version: 1.0.13
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Tomáš Golembiovský
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 18:22 UTC by jeffrey.m.kopera
Modified: 2018-05-10 13:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 13:15:00 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine.log file (150.51 KB, text/plain)
2018-05-07 15:42 UTC, jeffrey.m.kopera
no flags Details
vdsm.log file (49.97 KB, text/plain)
2018-05-09 14:42 UTC, jeffrey.m.kopera
no flags Details
engine.log file (1.82 MB, text/plain)
2018-05-09 14:44 UTC, jeffrey.m.kopera
no flags Details

Description jeffrey.m.kopera 2018-05-03 18:22:35 UTC
Description of problem: Single Sign on to VMs does not work in version 4.2 from the VM portal. Previously worked as expected in version 4.1 with the User Portal


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install ovirt-guest-agent-common, ovirt-guest-agent-pam-module, and ovirt-guest-agent-gdm-plugin packages
2. Open console from VM Portal

Actual results: User selection screen shows up


Expected results: Should login to the VM automatically as the user who is logged into the VM Portal.


Additional info:

Comment 1 Michal Skrivanek 2018-05-04 13:22:53 UTC
please attach logs from engine.log and the particular hosts's vdsm.log when the console is opened (make sure it covers the right time interval)

Comment 2 jeffrey.m.kopera 2018-05-07 15:42:26 UTC
Created attachment 1432694 [details]
engine.log file

Comment 3 jeffrey.m.kopera 2018-05-07 15:43:12 UTC
I attached the engine.log, there is no vdsm.log on the host.

Comment 4 Michal Skrivanek 2018-05-09 14:23:03 UTC
there has to be a vdsm log on dgsrds01 covering the time (May 7th 9:40am). That one would tell us if the guest agent request for SSO was send at all or whether it perhaps failed for some reason

Comment 5 jeffrey.m.kopera 2018-05-09 14:42:00 UTC
Created attachment 1433887 [details]
vdsm.log file

Comment 6 jeffrey.m.kopera 2018-05-09 14:44:39 UTC
Created attachment 1433888 [details]
engine.log file

Comment 7 jeffrey.m.kopera 2018-05-09 14:45:15 UTC
Sorry, I was looking in the wrong place.

I ran through trying to connect to the console again and provided the vdsm.log from that time period (May 9th 8:40am) and provided a new engine.log from the same time period.

Comment 8 Michal Skrivanek 2018-05-09 15:21:00 UTC
there's still no connection in the vdsm.log. Perhaps you have different TZ settings on host or you attached a log from wrong host, but it doesn't contain any connection to a console.

Comment 9 jeffrey.m.kopera 2018-05-09 15:33:29 UTC
TZ settings are the same. This is a test environment, so there's only the one host. I definitely connected  to the console in the time period those logs covered, not sure what other information I can provide that would be helpful.

Comment 10 Tomáš Golembiovský 2018-05-10 13:15:00 UTC
This issue is tracked on Web UI: https://github.com/oVirt/ovirt-web-ui/issues/65


Note You need to log in before you can comment on or make changes to this bug.