Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574660 - [CRI-O] master-restart script uses docker commands when control plane is running on crio [NEEDINFO]
Summary: [CRI-O] master-restart script uses docker commands when control plane is runn...
Keywords:
Status: CLOSED DUPLICATE of bug 1572440
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.10.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: Mrunal Patel
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 19:19 UTC by Mike Fiedler
Modified: 2018-05-21 09:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 09:38:51 UTC
Target Upstream Version:
haowang: needinfo? (ccoleman)


Attachments (Terms of Use)

Description Mike Fiedler 2018-05-03 19:19:25 UTC
Description of problem:

The master-restart shim is using docker commands directly.  This does not work when the control plane nodes are running cri-o.   Do we intend these commands for customer consumption?   I see TODOs in the scripts for cri-o but they are currently not implemented.


Version-Release number of selected component (if applicable):  3.10.0-0.32.0


How reproducible: Always


Steps to Reproduce:
1. On a cluster using cri-o as the container run time, master-restart api


Actual results:

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?


Expected results:

Master api restarts

Comment 1 Wang Haoran 2018-05-04 05:18:59 UTC
Hi, clayton, as you said we will using crictl instead in the master-restart scripts, do you have any plan when this will happen? will it be 3.10?

Comment 3 Antonio Murdaca 2018-05-21 09:38:51 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1572440

*** This bug has been marked as a duplicate of bug 1572440 ***


Note You need to log in before you can comment on or make changes to this bug.