Bug 1574681 - Support for disks 4kn
Summary: Support for disks 4kn
Keywords:
Status: CLOSED DUPLICATE of bug 1592916
Alias: None
Product: vdsm
Classification: oVirt
Component: Gluster
Version: 4.20.23
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-03 20:26 UTC by Marcelo Leandro
Modified: 2020-02-06 11:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-06 11:01:56 UTC
oVirt Team: Storage
tnisan: ovirt-future?


Attachments (Terms of Use)

Description Marcelo Leandro 2018-05-03 20:26:19 UTC
Description of problem:
Problem to add glusterFS configured with disks 4kn.

Version:
oVirt 4.1.9
Vdsm 4.20.23

How reproducible:
Configure glustesFS with disks 4kn and add in oVirt.


Actual results:
Not is accepted for oVirt.

Expected results:
Accepted 

Additional info:

This case is very like.

http://lists.ovirt.org/pipermail/users/2017-November/085157.html

Observations Nir in this case:

E-mail
" 
...
If this is important to you, I suggest to open an ovirt bug and explain
your use case.

You can also get someone to implement this. Note that this will not be easy
change, there
is lost of code assuming 512 bytes block size.

The change also require changes in sanlock. Vdsm and sanlock must agree on
the block
size used for a storage domain.

Nir

"


Very Thanks.

Comment 1 Marcelo Leandro 2018-06-06 14:13:29 UTC
Hello,

Exist any study to implement this support?

Thank you.

Comment 3 Sahina Bose 2020-02-06 11:01:56 UTC
(In reply to Marcelo Leandro from comment #1)
> Hello,
> 
> Exist any study to implement this support?
> 
> Thank you.

4KN support has been introduced in oVirt 4.3.8- see Bug 1592916

*** This bug has been marked as a duplicate of bug 1592916 ***


Note You need to log in before you can comment on or make changes to this bug.