Bug 1574761 - cups printing problem (Filter failed)
Summary: cups printing problem (Filter failed)
Keywords:
Status: CLOSED DUPLICATE of bug 1574177
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 01:11 UTC by Stephen So
Modified: 2018-05-04 04:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 04:28:05 UTC
Type: Bug


Attachments (Terms of Use)
error_log from using Ricoh C4504 PS PPD (10.21 MB, text/plain)
2018-05-04 01:11 UTC, Stephen So
no flags Details

Description Stephen So 2018-05-04 01:11:14 UTC
Created attachment 1430970 [details]
error_log from using Ricoh C4504 PS PPD

Description of problem:

After doing an upgrade from F27 to F28, my printing has stopped working.  It was working before, where I connect to a Ricoh C4504 printer over SMB.  However, after the upgrade to F28, it stopped working.  When I go into system-config-printer and hit the "Print Test Page", the Printer state shows "Processing", then after a while it shows "Idle - Filter failed".

I have tried to remove the printer entirely and reinstall it.  I'm using the Ricoh C4504 PS PPD file that it automatically downloads.

Version-Release number of selected component (if applicable):

cups-2.2.6-14.fc28.x86_64

How reproducible:

Always

Steps to Reproduce:
1.  Open up system-config-printer
2.  Press "Print Test Page"
3.  Observe the Printer state

Actual results:

It initially starts off as "Processing", but then it shows "Idle - Filter failed". Gnome notification shows the print job has been aborted.  And no printout on the printer.

Expected results:

It should print the CUPS test page.

Additional info:

I have attached the error_log from cups.

I've also tried doing a clean install of F28 in a virtualbox (to check whether it was because I did an upgrade), but it came up with the same error.  Then I did an install of F27 in a virtualbox, and the cups on there worked perfectly fine.

Comment 1 Zdenek Dohnal 2018-05-04 04:28:05 UTC
Hi Stephen,

thank you for reporting this issue! Your issue is duplicate of #1574177.

*** This bug has been marked as a duplicate of bug 1574177 ***


Note You need to log in before you can comment on or make changes to this bug.