Bug 1574769 - gnome-terminal could kill itself if you set formats to Chinese in Region&Language
Summary: gnome-terminal could kill itself if you set formats to Chinese in Region&Lang...
Keywords:
Status: CLOSED DUPLICATE of bug 1574222
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 02:08 UTC by Sean Fu
Modified: 2018-05-07 15:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 15:12:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Sean Fu 2018-05-04 02:08:14 UTC
Description of problem:
gnome-terminal could kill itself if you set formats to Chinese in Region&Language.When you set formats to English, gnome-terminal works well. 

Version-Release number of selected component (if applicable):
I just updated system to Fedora28

How reproducible:
Set formats to Chinese in Region&Language 

Steps to Reproduce:
1.Go to Setting-Region&Language
2.Select Chinese formats:汉语 
3.Restart, and login.Gnome-terminal can not be opened 

Actual results:
Login tty
run gnome-terminal,then:

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached


Expected results:
I need to use Chinese formats and gnome-terminal

Additional info:
NA

Comment 1 Christian Persch 2018-05-04 07:28:38 UTC
That probably is a non-UTF-8 locale, which isn't supported by gnome-terminal.

Comment 2 Bastien Nocera 2018-05-07 15:12:22 UTC

*** This bug has been marked as a duplicate of bug 1574222 ***


Note You need to log in before you can comment on or make changes to this bug.