Bug 1574777 - kernel-4.16.7-300.fc28.x86_64 locks up Intel NUC
Summary: kernel-4.16.7-300.fc28.x86_64 locks up Intel NUC
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 02:43 UTC by H.J. Lu
Modified: 2018-06-09 16:55 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-09 16:55:22 UTC
Type: Bug


Attachments (Terms of Use)

Description H.J. Lu 2018-05-04 02:43:01 UTC
I have an Intel NUC:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 540 (rev 0a)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1e.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO UART Controller #0 (rev 21)
00:1e.6 SD Host controller: Intel Corporation Sunrise Point-LP Secure Digital IO Controller (rev 21)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-V (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

kernel-4.16.7-300.fc28.x86_64 locks up it hard as soon as gdm starts.  Kernel
4.15.10 from Fedora 27 is OK.

Comment 1 H.J. Lu 2018-05-04 10:25:49 UTC
My NUC is NUC6i5SYB.  Fedora 27 with kernel 4.16.7-200.fc27.x86_64 works fine.

Comment 2 H.J. Lu 2018-05-05 13:23:20 UTC
I installed kernel 4.16.7-200.fc27.x86_64 on Fedora 28 and it works.
It looks like kernel-4.16.7-300.fc28.x86_64 is miscompiled by GCC 8.

Comment 3 H.J. Lu 2018-06-09 15:54:15 UTC
This is caused by kernel config change from Fedora 27 to Fedora 28:

@@ -2307,7 +2304,7 @@ CONFIG_SATA_PMP=y
 # Controllers with non-SFF native interface
 #
 CONFIG_SATA_AHCI=y
-CONFIG_SATA_MOBILE_LPM_POLICY=3  <<<<<<<<< Failed
+CONFIG_SATA_MOBILE_LPM_POLICY=0  <<<<<<<<< Works
 CONFIG_SATA_AHCI_PLATFORM=m
 CONFIG_SATA_INIC162X=m
 CONFIG_SATA_ACARD_AHCI=m

Comment 4 H.J. Lu 2018-06-09 16:55:22 UTC
Fixed by flushing BIOS to: SYSKLi35.86A.0066.2018.0517.1803


Note You need to log in before you can comment on or make changes to this bug.