Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1574779 (CVE-2018-10657) - CVE-2018-10657 matrix-synapse: Injection of malicious events with a depth size of 2^63-1 can cause a denial of service to making rooms unusable
Summary: CVE-2018-10657 matrix-synapse: Injection of malicious events with a depth siz...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2018-10657
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1574780
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 02:52 UTC by Sam Fowler
Modified: 2019-09-29 14:38 UTC (History)
1 user (show)

Fixed In Version: matrix-synapse 0.28.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:21:10 UTC


Attachments (Terms of Use)

Description Sam Fowler 2018-05-04 02:52:12 UTC
Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2^63 - 1 render rooms unusable, related to federation/federation_base.py and handlers/message.py, as exploited in the wild in April 2018.


External Reference:

https://matrix.org/blog/2018/05/01/security-update-synapse-0-28-1/


Upstream Patch:

https://github.com/matrix-org/synapse/commit/33f469ba19586bbafa0cf2c7d7c35463bdab87eb

Comment 1 Sam Fowler 2018-05-04 02:52:32 UTC
Created matrix-synapse tracking bugs for this issue:

Affects: fedora-all [bug 1574780]

Comment 2 Product Security DevOps Team 2019-06-10 10:21:10 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.