Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574782 - Only project.* index is shown on kibana, there is not individual project index
Summary: Only project.* index is shown on kibana, there is not individual project index
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 03:01 UTC by Junqi Zhao
Modified: 2018-05-07 13:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 01:51:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Only project.* index is shown on kibana, there is not individual project index (204.70 KB, image/png)
2018-05-04 03:01 UTC, Junqi Zhao
no flags Details
project.* index and individual project index could be viewed in kibana (153.30 KB, image/png)
2018-05-07 03:17 UTC, Junqi Zhao
no flags Details

Description Junqi Zhao 2018-05-04 03:01:14 UTC
Created attachment 1430997 [details]
Only project.* index is shown on kibana, there is not individual project index

Description of problem:
Only project.* index is shown on kibana, there is not individual project index, but logs of all project could be found under project.* index

Version-Release number of selected component (if applicable):
logging-elasticsearch/images/v3.9.27-2
logging-fluentd/images/v3.9.27-2
logging-curator/images/v3.9.27-2
logging-kibana/images/v3.9.27-2
logging-auth-proxy/images/v3.9.27-2

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging 3.9 and logon kibana
2.
3.

Actual results:
Only project.* index is shown on kibana, there is not individual project index

Expected results:
Should have individual project index on kibana

Additional info:

Comment 1 Jeff Cantrill 2018-05-04 13:15:36 UTC
Please confirm you are logged in as a cluster admin.  This change is intentional as part of [1] to support larger online clusters.  I expect for non-admins you should see the pattern per namespace as was previously the case.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1563230

Comment 2 Junqi Zhao 2018-05-07 01:51:00 UTC
Yes, logged in as a cluster admin only could see project.* index, not the individual project index, use non-admins could see the pattern per namespace as was previously the case.

Close it as NOTABUG

Comment 3 Junqi Zhao 2018-05-07 03:16:34 UTC
There is one corner case, if use one non-admin to create a project and populate logs, we could see index pattern project.<namespace>.<UUID>.<date> in kibana UI, if then make this user to cluster-admin later, both project.* and project.<namespace>.<UUID>.<date> indices could be viewed in kibana UI.

Is that expected?

Comment 4 Junqi Zhao 2018-05-07 03:17:54 UTC
Created attachment 1432477 [details]
project.* index and individual project index could be viewed in kibana

Comment 5 Jeff Cantrill 2018-05-07 13:25:30 UTC
It's only expected in that the plugin does not account for this corner case.  It makes no effort to modify existing index-patterns so that user customizations are  not lost.  In this particular case, a non-admin trying to query using the 'project.*' index-pattern will see 403 errors because the are trying to search indices for which they do not have permissions.


Note You need to log in before you can comment on or make changes to this bug.