Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574795 - logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
Summary: logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 04:11 UTC by Knut J BJuland
Modified: 2019-08-20 19:02 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-20 19:02:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Knut J BJuland 2018-05-04 04:11:12 UTC
Description of problem:
logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device

Version-Release number of selected component (if applicable):
4.16.6-300.fc28.x86_64
How reproducible:
boot

Steps to Reproduce:
1. boot


Actual results:

logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 1196.629789] FAT-fs (sdc1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 1533.064731] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based  firewall rule not found. Use the iptables CT target to attach helpers instead.
[ 2433.714937] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 2559.688412] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 3043.011504] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 3517.810966] perf: interrupt took too long (2504 > 2500), lowering kernel.perf_event_max_sample_rate to 79000
[ 3791.136759] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 4183.775502] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 4183.874863] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 4278.773190] perf: interrupt took too long (3131 > 3130), lowering kernel.perf_event_max_sample_rate to 63000
[ 6036.750777] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 6609.491527] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 7460.659075] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 7698.441833] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 8126.275934] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[24298.998493] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[24654.056901] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[25214.060697] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[27155.752653] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[52550.562320] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[53523.406652] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[54104.490709] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[54971.892139] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[72411.629837] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[75101.687063] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[75236.660571] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[77012.519733] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[77323.025195] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[77698.939346] usb 1-13.4.2.1: USB disconnect, device number 8
[77708.596429] usb 1-13.4.1: new full-speed USB device number 11 using xhci_hcd
[77708.724566] usb 1-13.4.1: New USB device found, idVendor=0a12, idProduct=0001
[77708.724571] usb 1-13.4.1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[77708.724573] usb 1-13.4.1: Product: CSR8510 A10
[78401.099059] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[81119.572205] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[82322.094120] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[82510.472644] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[84088.026917] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[84926.547304] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[86962.467929] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[88084.366124] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[90055.025488] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[108798.755883] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[110819.203464] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[137827.417974] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device



Expected results:


Additional info:

Comment 1 Knut J BJuland 2018-05-05 03:56:20 UTC
[187940.572126] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[187940.572129] usb 1-11: Product: USB Receiver
[187940.572132] usb 1-11: Manufacturer: Logitech
[187940.582124] logitech-djreceiver 0003:046D:C52B.0008: hiddev96,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-11/input2
[187940.697881] input: Logitech M705 as /devices/pci0000:00/0000:00:14.0/usb1/1-11/1-11:1.2/0003:046D:C52B.0008/0003:046D:101B.0009/input/input19
[187940.698471] logitech-hidpp-device 0003:046D:101B.0009: input,hidraw2: USB HID v1.11 Mouse [Logitech M705] on usb-0000:00:14.0-11:1
[187940.705887] input: Logitech MK700 as /devices/pci0000:00/0000:00:14.0/usb1/1-11/1-11:1.2/0003:046D:C52B.0008/0003:046D:2008.000A/input/input20
[187940.706121] logitech-hidpp-device 0003:046D:2008.000A: input,hidraw3: USB HID v1.11 Keyboard [Logitech MK700] on usb-0000:00:14.0-11:2
[187947.165819] logitech-hidpp-device 0003:046D:101B.0009: HID++ 1.0 device connected.
[187956.463882] logitech-hidpp-device 0003:046D:2008.000A: HID++ 3.0 device connected.
[187956.471820] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[188260.666053] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[188295.913921] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[188600.130666] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[189449.336240] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[192601.511976] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[194572.225712] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[195473.904702] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[195619.874000] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[198538.302226] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[222340.947407] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[223633.394549] EDAC skx: ECC is disabled on imc 0
[223847.782670] EDAC skx: ECC is disabled on imc 0

Comment 2 Knut J BJuland 2018-05-05 03:58:52 UTC
I have a mk710 logitech wireless keyboard and the kernel is unable to get this name.

Comment 3 Justin M. Forbes 2018-07-23 15:21:19 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.

Fedora 27 has now been rebased to 4.17.7-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 28, and are still experiencing this issue, please change the version to Fedora 28.

If you experience different issues, please open a new bug report for those.

Comment 4 Knut J BJuland 2018-07-24 07:58:02 UTC
logitech-hidpp-device 0003:046D:2008.0005: HID++ 3.0 device connected.
[ 1241.144430] logitech-hidpp-device 0003:046D:2008.0005: unable to retrieve the name of the device
[ 1273.174432] logitech-hidpp-device 0003:046D:101B.0004: HID++ 1.0 device connected.

With fedora 28 and Linux knut.localdomain 4.17.7-200.fc28.x86_64 #1 SMP Tue Jul 17 16:28:31 UTC 2018 x86_64 x86_64 x86_64

Comment 5 Knut J BJuland 2018-07-24 08:05:56 UTC
I have a M705 wireless keyboard and a MK700 Marthon mouse from logitech.

Comment 6 Peter Larsen 2018-08-08 13:48:43 UTC
Reproduced, Fedora 28
Device failing: 
Bus 003 Device 005: ID 046d:c52f Logitech, Inc. Unifying Receiver

Comment 7 devsk 2018-09-21 03:15:21 UTC
This is just another "me too". Its filling up system logs

Comment 8 Justin M. Forbes 2019-01-29 16:26:25 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.

Fedora 28 has now been rebased to 4.20.5-100.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.

If you experience different issues, please open a new bug report for those.

Comment 9 Alexander Ploumistos 2019-01-29 16:57:59 UTC
Just tested with 4.20.4-200.fc29, it's still there.

Comment 10 Knut J BJuland 2019-04-15 00:16:18 UTC
I have test it with kernel-5.0.7-300.fc30.x86_64 and it is still there. Now there is after a time I can not use the mouse to click on windows both in KDE and Gnome. How can I debug this problem and give you more information?

Comment 11 Knut J BJuland 2019-04-15 00:16:59 UTC
[38239.236294] logitech-djreceiver 0003:046D:C52B.0008: hiddev96,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-13.4.1/input2
[38239.351855] input: Logitech M705 as /devices/pci0000:00/0000:00:14.0/usb1/1-13/1-13.4/1-13.4.1/1-13.4.1:1.2/0003:046D:C52B.0008/0003:046D:101B.0009/input/input29
[38239.352138] logitech-hidpp-device 0003:046D:101B.0009: input,hidraw1: USB HID v1.11 Mouse [Logitech M705] on usb-0000:00:14.0-13.4.1:1
[38239.360223] input: Logitech MK700 as /devices/pci0000:00/0000:00:14.0/usb1/1-13/1-13.4/1-13.4.1/1-13.4.1:1.2/0003:046D:C52B.0008/0003:046D:2008.000A/input/input30
[38239.360426] logitech-hidpp-device 0003:046D:2008.000A: input,hidraw2: USB HID v1.11 Keyboard [Logitech MK700] on usb-0000:00:14.0-13.4.1:2
[38240.561784] logitech-hidpp-device 0003:046D:101B.0009: HID++ 1.0 device connected.
[38240.663726] logitech-hidpp-device 0003:046D:101B.0009: multiplier = 8
[38248.545788] logitech-hidpp-device 0003:046D:2008.000A: HID++ 3.0 device connected.
[38248.553778] logitech-hidpp-device 0003:046D:2008.000A: unable to retrieve the name of the device
[38261.280452] fbcon: Taking over console

Comment 12 Justin M. Forbes 2019-08-20 17:44:10 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 5.2.9-100.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 30, and are still experiencing this issue, please change the version to Fedora 30.

If you experience different issues, please open a new bug report for those.

Comment 13 Knut J BJuland 2019-08-20 17:59:14 UTC
resolved with latest kernel
[65677.103153] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[72290.369856] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[74349.328485] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[82087.365675] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[86377.793209] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[93531.395066] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8
[97291.637399] logitech-hidpp-device 0003:046D:101B.0004: multiplier = 8

Comment 14 Justin M. Forbes 2019-08-20 19:02:21 UTC
Thanks for the update.


Note You need to log in before you can comment on or make changes to this bug.