Bug 1574803 - Allow a user to disable a list of repositories of their choice for a given distro tree
Summary: Allow a user to disable a list of repositories of their choice for a given di...
Keywords:
Status: CLOSED DUPLICATE of bug 1664750
Alias: None
Product: Beaker
Classification: Retired
Component: general
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 05:11 UTC by Roman Joost
Modified: 2019-02-18 12:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 12:03:15 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1554472 1 None None None 2021-01-20 06:05:38 UTC

Internal Links: 1554472

Description Roman Joost 2018-05-04 05:11:08 UTC
Description of problem:

Based on Bug 1554472#c37 the distro_importer will enable all RHEL8 repos. Yet certain users want to minimize the amount of automatically enabled repositories during testing to avoid tainting the system with packages from said repositories. Instead of starting from a system with all repositories enabled, they need a minimal base system.

Since Bug 1554472 enables all repositories, Beaker should provide a way for users to disable repositories with a ks_meta variable.

Comment 1 Roman Joost 2018-05-04 05:14:27 UTC
Idea:

Based on Jan's idea from Bug 1554472 comment 37 we could use the repoid in form of a: no_<repoid>_repos. In reality that would become:

* no_Buildroot_repos
* no_AppStream_repos

etc.

The only problem with repoid is, that it can be camelcase and contain hyphens. For example:

* AppStream
* ComputeNode-optional-debuginfo

Should these ids be normalised? Kept as is?

Comment 4 Roman Joost 2018-05-30 22:18:22 UTC
With RCM's efforts to move to unified composes, I think this item is of less priority after beta. The core tho still stands: If we have BaseOS + AppStream imported as a single compose, Buildroot will still be shipped as a separate and enabling all of them seem to be not the best choice. I'll raise this topic on the mailing list in order to get more ideas how we can implement something which works for everyone.

Comment 5 Prarit Bhargava 2018-06-04 11:31:43 UTC
(In reply to Roman Joost from comment #1)
> Idea:
> 
> Based on Jan's idea from Bug 1554472 comment 37 we could use the repoid in
> form of a: no_<repoid>_repos. In reality that would become:
> 
> * no_Buildroot_repos
> * no_AppStream_repos
> 
> etc.

In the future we have no idea if the repos will be called BUILDROOT, AppStream, etc.  I think you want to do something like

OS.action.noun.object

ie)

rhel8.disable.repo.BUILDROOT

or

rhel7.enable.repo.Optional

If the names of the repos change in the future, and this is code properly, it should be easy to extend the options.  That way you don't end up ks_meta data hell :)

> 
> The only problem with repoid is, that it can be camelcase and contain
> hyphens. For example:
> 
> * AppStream
> * ComputeNode-optional-debuginfo
> 
> Should these ids be normalised? Kept as is?

IMO.

P.

Comment 10 Martin Styk 2019-02-18 12:03:15 UTC

*** This bug has been marked as a duplicate of bug 1664750 ***


Note You need to log in before you can comment on or make changes to this bug.