Bug 1574833 - Kernels 4.15, 4.16 and 4.17 hang at boot most of the times
Summary: Kernels 4.15, 4.16 and 4.17 hang at boot most of the times
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 06:24 UTC by giacomo82
Modified: 2018-10-15 11:20 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-15 11:20:28 UTC
Type: Bug


Attachments (Terms of Use)

Description giacomo82 2018-05-04 06:24:03 UTC
Description of problem:
I'm using F27 with 4.14 kernel without any problem.
If I try to upgrade the kernel to the proposed 4.15 or the new 4.16 (shipped with F28), most of the times my laptop (Dell 5510) hangs at boot, becoming completely unresponsive (I have to hold the power button). 
Something like 1 boot on 3 goes fine and the PC runs smoothly.
From the journal the last things I can read:

mag 03 22:02:02 giacomo-linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-random-seed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 22:02:02 giacomo-linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fedora-readonly comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 22:02:02 giacomo-linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-tmpfiles-setup-dev comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 22:02:02 giacomo-linux systemd-journald[522]: System journal (/var/log/journal/0b5886a60d454e6fbe66d3ad4e96d331) is 2.4G, max 4.0G, 1.5G free.
mag 03 22:02:02 giacomo-linux systemd-journald[522]: Time spent on flushing to /var is 41.569ms for 1108 entries.
mag 03 22:02:02 giacomo-linux systemd[1]: Starting udev Coldplug all Devices...
mag 03 22:02:02 giacomo-linux systemd[1]: Starting Configure read-only root support...
mag 03 22:02:02 giacomo-linux systemd[1]: Starting Create Static Device Nodes in /dev...
mag 03 22:02:02 giacomo-linux systemd[1]: Starting Flush Journal to Persistent Storage...
mag 03 22:02:02 giacomo-linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-remount-fs comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 22:02:02 giacomo-linux systemd[1]: Started Remount Root and Kernel File Systems.
mag 03 22:02:02 giacomo-linux kernel: BTRFS info (device sda4): disk space caching is enabled
mag 03 22:02:02 giacomo-linux audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-sysctl comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
mag 03 22:02:02 giacomo-linux systemd[1]: Started Apply Kernel Variables.


Version-Release number of selected component (if applicable):
kernel-4.15.10-300.fc27.x86_64
kernel-4.16.5-200.fc27.x86_64 

How reproducible:
Simply boot up the PC

Steps to Reproduce:
1.
2.
3.

Actual results:
PC hangs with the console on and completely unresponsive

Expected results:
Normal boot.

Additional info:
Dell 5510 with 4K screen

lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:16.3 Serial controller: Intel Corporation Sunrise Point-H KT Redirection (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.1 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)
00:1d.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107GLM [Quadro M1000M] (rev a2)
02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
04:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961
06:00.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
07:00.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
07:01.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
07:02.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
3e:00.0 USB controller: Intel Corporation DSL6340 USB 3.1 Controller [Alpine Ridge]

lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              8
On-line CPU(s) list: 0-7
Thread(s) per core:  2
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               94
Model name:          Intel(R) Core(TM) i7-6820HQ CPU @ 2.70GHz
Stepping:            3
CPU MHz:             900.151
CPU max MHz:         3600,0000
CPU min MHz:         800,0000
BogoMIPS:            5424.00
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            8192K
NUMA node0 CPU(s):   0-7
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb invpcid_single pti tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp

Comment 1 Justin M. Forbes 2018-07-23 15:25:23 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.

Fedora 27 has now been rebased to 4.17.7-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 28, and are still experiencing this issue, please change the version to Fedora 28.

If you experience different issues, please open a new bug report for those.

Comment 2 giacomo82 2018-07-23 15:49:21 UTC
Hi, I moved to FC28 and, unluckily, the bug is still here.
4.17.7

Comment 3 giacomo82 2018-07-23 15:53:25 UTC
(In reply to giacomo82 from comment #2)
> Hi, I moved to FC28 and, unluckily, the bug is still here.
> 4.17.7

Sorry, I saved without finishing.
I moved to FC28 with 4.17.7 kernel and I still cannot boot most of the times. Now I have to manually install 4.14.18-300 (from FC27) to be able to use my PC.
Thanks.

Comment 4 Laura Abbott 2018-10-01 21:31:55 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 28 kernel bugs.
 
Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 29, and are still experiencing this issue, please change the version to Fedora 29.
 
If you experience different issues, please open a new bug report for those.

Comment 5 giacomo82 2018-10-15 11:20:28 UTC
(In reply to Laura Abbott from comment #4)
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 28 kernel bugs.
>  
> Fedora 28 has now been rebased to 4.18.10-300.fc28.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
>  
> If you have moved on to Fedora 29, and are still experiencing this issue,
> please change the version to Fedora 29.
>  
> If you experience different issues, please open a new bug report for those.

Hi,
I can confirm the bug has been resolved with the 4.18 kernel. It boots normally.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.