Bug 1574840 - psi-plus 1.0 crashes with SIGSEGV randomly
Summary: psi-plus 1.0 crashes with SIGSEGV randomly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: psi-plus
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 07:01 UTC by Michal Špondr
Modified: 2018-09-21 05:24 UTC (History)
2 users (show)

Fixed In Version: psi-plus-1.3.408-1.fc28 psi-plus-1.3.408-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-13 19:00:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Špondr 2018-05-04 07:01:57 UTC
Description of problem:
psi-plus is crashing randomly at start

Version-Release number of selected component (if applicable):
$sudo dnf info psi-plus
Last metadata expiration check: 0:09:03 ago on Fri 04 May 2018 08:45:51 AM CEST.
Installed Packages
Name         : psi-plus
Epoch        : 1
Version      : 1.0
Release      : 0.6.20170612git9.fc28
Arch         : x86_64
Size         : 8.8 M
Source       : psi-plus-1.0-0.6.20170612git9.fc28.src.rpm
Repo         : @System
From repo    : fedora
Summary      : Jabber client based on Qt
URL          : http://code.google.com/p/psi-dev/
License      : GPLv2+ and LGPLv2+ and zlib
Description  : Psi+ - Psi IM Mod by psi-dev@conference.jabber.ru



How reproducible:
It happens randomly, I have to run it cca. 5-times before it's stable. The client is connecting to a MUC automatically, but I am not sure if it's the reason. For a brief moment the app is displayed, it connects to MUC, but it crashes instantly.


Steps to Reproduce:
1. Run psi-plus
2. It crashes randomly
3.

Actual results:
$ psi-plus 
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
[20180504 8:52:44] W:libpng warning: iCCP: known incorrect sRGB profile (unknown:0, unknown)
Segmentation fault (core dumped)


(gdb) bt
#0  0x0000000000773d10 in  ()
#1  0x000000000082ab39 in  ()
#2  0x00000000008049fe in  ()
#3  0x0000000000804dfb in  ()
#4  0x000000000080618c in  ()
#5  0x000000000090effc in  ()
#6  0x00007ffff2483cbe in QMetaObject::activate(QObject*, int, int, void**) () at /lib64/libQt5Core.so.5
#7  0x00007ffff248fe1b in QTimer::timeout(QTimer::QPrivateSignal) () at /lib64/libQt5Core.so.5
#8  0x00007ffff24849db in QObject::event(QEvent*) () at /lib64/libQt5Core.so.5
#9  0x00007ffff5d9ae95 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#10 0x00007ffff5da283a in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#11 0x00007ffff245b376 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#12 0x00007ffff24aaf19 in QTimerInfoList::activateTimers() () at /lib64/libQt5Core.so.5
#13 0x00007ffff24ab7bc in timerSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#14 0x00007ffff68387cd in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#15 0x00007ffff6838b98 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#16 0x00007ffff6838c30 in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#17 0x00007ffff24abc13 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#18 0x00007fffe40f7065 in QPAEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5XcbQpa.so.5
#19 0x00007ffff245a12b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#20 0x00007ffff24625b6 in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#21 0x00000000004f5e67 in main ()



Expected results:
It should not crash.

Additional info:

Comment 1 Kevin Kofler 2018-05-06 22:19:05 UTC
This backtrace looks like it is calling a slot of an already deleted object. Use Valgrind to find where the object is being deleted, that delete needs to be changed to a deleteLater.

Comment 2 Michal Špondr 2018-05-07 13:33:04 UTC
I am not able to reproduce it with Valgrind.

Comment 3 Michal Špondr 2018-05-16 06:49:14 UTC
I've found out the crashing stopped after I removed OpenPGP keys from jabber account.

Comment 4 Fedora Update System 2018-08-30 00:02:33 UTC
psi-plus-1.3.408-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ab1654e44

Comment 5 Fedora Update System 2018-08-30 15:00:57 UTC
psi-plus-1.3.408-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ab1654e44

Comment 6 Fedora Update System 2018-09-01 08:20:28 UTC
psi-plus-1.3.408-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-18eece808b

Comment 7 Fedora Update System 2018-09-02 06:45:08 UTC
psi-plus-1.3.408-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-18eece808b

Comment 8 Fedora Update System 2018-09-13 19:00:00 UTC
psi-plus-1.3.408-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-09-21 05:24:11 UTC
psi-plus-1.3.408-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.