Bug 1574885 - Fedora 28 upgrade causes perl downgrade
Summary: Fedora 28 upgrade causes perl downgrade
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 09:20 UTC by Joergen Thomsen
Modified: 2018-05-04 12:04 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 12:04:28 UTC
Type: Bug


Attachments (Terms of Use)
The dnf output (169.79 KB, text/plain)
2018-05-04 09:37 UTC, Joergen Thomsen
no flags Details

Description Joergen Thomsen 2018-05-04 09:20:57 UTC
Description of problem:
Upgrade to Fedora 28 cause downgrade of perl and other

Version-Release number of selected component (if applicable):
Fedora 27 

How reproducible:

every time

Steps to Reproduce:
1. dnf --refresh upgrade
2.dnf system-upgrade download --releasever=28
3.

Actual results:

Downgrading:
 librados2  x86_64 1:12.2.4-1.fc28   fedora                           3.0 M
 libtirpc   x86_64 1.0.3-1.rc1.fc28  updates                          110 k
 perl       x86_64 4:5.26.1-409.fc28 fedora                            69 k
 perl-devel x86_64 4:5.26.1-409.fc28 fedora                           595 k
 perl-interpreter x86_64 4:5.26.1-409.fc28 fedora                     6.2 M
 perl-libnetcfg   noarch 4:5.26.1-409.fc28 fedora                      74 k
 perl-libs        x86_64 4:5.26.1-409.fc28 fedora                     1.6 M
 perl-macros x86_64 4:5.26.1-409.fc28      fedora                      69 k
 perl-utils  noarch 5.26.1-409.fc28        fedora                     126 k


Expected results:

no downgrade of packages

Additional info:

Comment 1 Joergen Thomsen 2018-05-04 09:23:59 UTC
perl-PAR-Packer is not installed
This is not a duplicate of bug 1570874 perl-PAR-Packer

Comment 2 Joergen Thomsen 2018-05-04 09:37:20 UTC
Created attachment 1431175 [details]
The dnf output

Comment 3 Petr Pisar 2018-05-04 12:04:28 UTC
perl-5.26.2-410.fc28 packages was stuck in Bodhi system between "requested for testing" state and "pushed into testing" state.

See <https://bodhi.fedoraproject.org/updates/perl-5.26.2-410.fc28%20perl-Module-CoreList-5.20180414-1.fc28#comment-774671>.

This is Fedora infrastructure problem and perl maintainters cannot do anything with it. You have to wait until the package get tested, then pushed into updates repository and finally mirrored on the Internet sites.


Note You need to log in before you can comment on or make changes to this bug.