Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1574886 - nagios-plugins-perl-2.2.1-9git5c7eb5b9.el7 does not provide "perl(utils)"
Summary: nagios-plugins-perl-2.2.1-9git5c7eb5b9.el7 does not provide "perl(utils)"
Keywords:
Status: CLOSED DUPLICATE of bug 1572361
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 09:21 UTC by Pim Rupert
Modified: 2018-05-04 13:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-04 13:22:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Pim Rupert 2018-05-04 09:21:07 UTC
Description of problem:

Package nagios-plugins-perl does not provide "perl(utils)" dependency. This prevents plugins from being installed that have a dependency on "perl(utils)", resulting in the yum error: "Error: Package: <some-plugin>\n           Requires: perl(utils)\n"

Version-Release number of selected component (if applicable):

2.2.1-9git5c7eb5b9.el7

Actual results:

# rpm -q --provides nagios-plugins-perl
nagios-plugins-perl = 2.2.1-9git5c7eb5b9.el7
nagios-plugins-perl(x86-64) = 2.2.1-9git5c7eb5b9.el7

Expected results:

Old version does provide "perl(utils)":

rpm -q --provides nagios-plugins-perl
nagios-plugins-perl = 2.2.1-4git.el7
nagios-plugins-perl(x86-64) = 2.2.1-4git.el7
perl(utils)

Additional info:

Current missing "provides" breaks dependency chain for some plugins that require the perl(utils) module.

Comment 1 Stephen John Smoogen 2018-05-04 13:22:11 UTC
It seems the provides was faulty and was causing problems for other packages. The fix is that the sub-packages need to be rebuilt as per the instructions the perl team left in 1572361

Packages that require perl(utils), that is not provided by anything, should filter out the dependency from RPM metadata using:

%global __requires_exclude %{?__requires_exclude:%__requires_exclude}|}^perl\\(utils\\)

This is how auto-generated dependencies are filtered in Fedora and EPEL-7. Older EPELs use different syntax/methods for filtering. See <https://fedoraproject.org/wiki/Packaging:AutoProvidesAndRequiresFiltering> for more details.

*** This bug has been marked as a duplicate of bug 1572361 ***


Note You need to log in before you can comment on or make changes to this bug.