Bug 1574912 - UI exception on new VM from template
Summary: UI exception on new VM from template
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.3.2
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 10:46 UTC by Sahina Bose
Modified: 2018-05-09 14:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 14:54:23 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Sahina Bose 2018-05-04 10:46:14 UTC
Description of problem:

UI does not load on clicking on "New VM" from Template screen

2018-05-04 16:10:32,149+05 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-28) [] Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) : a.o.qb.Db is undefined
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior.$lambda$1(NewVmModelBehavior.java:111)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior$lambda$1$Type.finished(NewVmModelBehavior.java:111)
        at org.ovirt.engine.ui.uicommonweb.builders.BuilderExecutor$BuilderExecutionFinishedCaller.build(BuilderExecutor.java:80)
        at org.ovirt.engine.ui.uicommonweb.builders.CompositeBuilder$LastBuilder.build(CompositeBuilder.java:45)
        at org.ovirt.engine.ui.uicommonweb.builders.vm.IconVmBaseToUnitBuilder.lambda$0(IconVmBaseToUnitBuilder.java:23)
        at org.ovirt.engine.ui.uicommonweb.builders.vm.IconVmBaseToUnitBuilder$lambda$0$Type.onSuccess(IconVmBaseToUnitBuilder.java:23)
        at org.ovirt.engine.ui.uicommonweb.models.vms.IconCache.$getOrFetchIcons(IconCache.java:50)
        at org.ovirt.engine.ui.uicommonweb.builders.vm.IconVmBaseToUnitBuilder.$build(IconVmBaseToUnitBuilder.java:18)
        at org.ovirt.engine.ui.uicommonweb.builders.vm.IconVmBaseToUnitBuilder.build(IconVmBaseToUnitBuilder.java:18)
        at org.ovirt.engine.ui.uicommonweb.builders.BaseSyncBuilder.build(BaseSyncBuilder.java:13)
        at org.ovirt.engine.ui.uicommonweb.builders.BaseSyncBuilder.build(BaseSyncBuilder.java:13)
        at org.ovirt.engine.ui.uicommonweb.builders.CompositeBuilder.build(CompositeBuilder.java:21)
        at org.ovirt.engine.ui.uicommonweb.builders.BuilderExecutor.$build(BuilderExecutor.java:61)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior.$buildModel(NewVmModelBehavior.java:188)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior.templateWithVersion_SelectedItemChanged(NewVmModelBehavior.java:101)
        at org.ovirt.engine.ui.uicommonweb.models.vms.UnitVmModel.eventRaised(UnitVmModel.java:1920)
        at org.ovirt.engine.ui.uicompat.Event.$raise(Event.java:99)
        at org.ovirt.engine.ui.uicommonweb.models.ListModel.$setSelectedItem(ListModel.java:82)
        at org.ovirt.engine.ui.uicommonweb.models.ListModel.setSelectedItem(ListModel.java:78)
        at org.ovirt.engine.ui.uicommonweb.models.ListModel.$itemsChanged(ListModel.java:227)
        at org.ovirt.engine.ui.uicommonweb.models.ListModel.$setItems(ListModel.java:102)
        at org.ovirt.engine.ui.uicommonweb.models.vms.VmModelBehaviorBase.$initTemplateWithVersion(VmModelBehaviorBase.java:283)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmFromTemplateModelBehavior.postInitTemplate(NewVmFromTemplateModelBehavior.java:25)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior.$lambda$3(NewVmModelBehavior.java:275)
        at org.ovirt.engine.ui.uicommonweb.models.vms.NewVmModelBehavior$lambda$3$Type.onSuccess(NewVmModelBehavior.java:275)
        at org.ovirt.engine.ui.frontend.Frontend$1.$onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.Frontend$1.onSuccess(Frontend.java:227) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.$onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.OperationProcessor$1.onSuccess(OperationProcessor.java:133) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.$onSuccess(GWTRPCCommunicationProvider.java:270) [frontend.jar:]
        at org.ovirt.engine.ui.frontend.communication.GWTRPCCommunicationProvider$5$1.onSuccess(GWTRPCCommunicationProvider.java:270) [frontend.jar:]
        at com.google.gwt.user.client.rpc.impl.RequestCallbackAdapter.onResponseReceived(RequestCallbackAdapter.java:198) [gwt-servlet.jar:]
        at com.google.gwt.http.client.Request.$fireOnResponseReceived(Request.java:233) [gwt-servlet.jar:]
        at com.google.gwt.http.client.RequestBuilder$1.onReadyStateChange(RequestBuilder.java:409) [gwt-servlet.jar:]
        at Unknown.onreadystatechange<(https://rhhi-engine1.redhat.com/ovirt-engine/webadmin/?locale=en_US#hosts)


Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.3.4-0.1.el7.noarch

How reproducible:
Always

Comment 1 Michal Skrivanek 2018-05-05 04:26:48 UTC
Please describe your environment and the templete. Does it work in other version?

Comment 2 Sahina Bose 2018-05-05 15:45:37 UTC
(In reply to Michal Skrivanek from comment #1)
> Please describe your environment and the templete. Does it work in other
> version?

The template was created from a minimal-Centos.iso. The VM creation works for the flow - New VM -> select template and create.
Fails when tried using user flow -> Templates screen, select template -> New VM.

The enviroment is a RHHI deployment with 3 hosts, and VM images on gluster volume.

I haven't tried with the same template in earlier version. However, the New VM from Templates screen works on another environment with Version 4.2.3.3-0.1.el7

Comment 3 Sahina Bose 2018-05-09 14:54:23 UTC
I could not reproduce this error again, hence closing this.


Note You need to log in before you can comment on or make changes to this bug.