Bug 1574917 - pyanaconda.payload.PayloadError: Payload error - DNF installation has ended up abruptly: ipa-common conflicts with (installed) freeipa-common-4.6.90.pre1-6.1.fc28.noarchTraceback (most recent call last):
Summary: pyanaconda.payload.PayloadError: Payload error - DNF installation has ended u...
Keywords:
Status: CLOSED DUPLICATE of bug 1575131
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4683b74eb23d52639593b97a234...
: 1592622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 11:02 UTC by morgan read
Modified: 2018-11-12 14:43 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-12 14:43:37 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda.log (103.46 KB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: dbus.log (3.13 KB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: dnf.librepo.log (2.59 MB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: environ (636 bytes, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: hawkey.log (121.83 KB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: lorax-packages.log (25.49 KB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: lsblk_output (4.35 KB, text/plain)
2018-05-04 11:02 UTC, morgan read
no flags Details
File: lvm.log (4.72 MB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: nmcli_dev_list (1.59 KB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: os_info (556 bytes, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: program.log (252.68 KB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: storage.log (788.24 KB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: syslog (1.82 MB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: ifcfg.log (108 bytes, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: packaging.log (108.60 KB, text/plain)
2018-05-04 11:03 UTC, morgan read
no flags Details
File: anaconda-tb (11.54 MB, text/plain)
2018-05-04 11:04 UTC, morgan read
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1575131 None None None Never

Internal Links: 1575131

Description morgan read 2018-05-04 11:02:27 UTC
Description of problem:
Installed f28 Workstation from f28 Server netinstall iso on usb stick

Version-Release number of selected component:
anaconda-28.22.10

The following was filed automatically by anaconda:
anaconda 28.22.10 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/payload/dnfpayload.py", line 965, in install
    raise payload.PayloadError(msg)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 361, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 291, in run
    threading.Thread.run(self)
pyanaconda.payload.PayloadError: Payload error - DNF installation has ended up abruptly: ipa-common conflicts with (installed) freeipa-common-4.6.90.pre1-6.1.fc28.noarchTraceback (most recent call last):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/payload/dnfpayload.py", line 279, in do_transaction
    base.do_transaction(display=display)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 867, in do_transaction
    raise dnf.exceptions.TransactionCheckError(msg)
dnf.exceptions.TransactionCheckError: ipa-common conflicts with (installed) freeipa-common-4.6.90.pre1-6.1.fc28.noarch


Additional info:
addons:         com_redhat_kdump, com_redhat_docker
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-28 rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.16.3-301.fc28.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        28

Potential duplicate: bug 1514998

Comment 1 morgan read 2018-05-04 11:02:36 UTC
Created attachment 1431256 [details]
File: anaconda.log

Comment 2 morgan read 2018-05-04 11:02:37 UTC
Created attachment 1431257 [details]
File: dbus.log

Comment 3 morgan read 2018-05-04 11:02:51 UTC
Created attachment 1431258 [details]
File: dnf.librepo.log

Comment 4 morgan read 2018-05-04 11:02:52 UTC
Created attachment 1431259 [details]
File: environ

Comment 5 morgan read 2018-05-04 11:02:55 UTC
Created attachment 1431260 [details]
File: hawkey.log

Comment 6 morgan read 2018-05-04 11:02:57 UTC
Created attachment 1431261 [details]
File: lorax-packages.log

Comment 7 morgan read 2018-05-04 11:02:59 UTC
Created attachment 1431262 [details]
File: lsblk_output

Comment 8 morgan read 2018-05-04 11:03:15 UTC
Created attachment 1431263 [details]
File: lvm.log

Comment 9 morgan read 2018-05-04 11:03:18 UTC
Created attachment 1431264 [details]
File: nmcli_dev_list

Comment 10 morgan read 2018-05-04 11:03:20 UTC
Created attachment 1431265 [details]
File: os_info

Comment 11 morgan read 2018-05-04 11:03:24 UTC
Created attachment 1431266 [details]
File: program.log

Comment 12 morgan read 2018-05-04 11:03:30 UTC
Created attachment 1431267 [details]
File: storage.log

Comment 13 morgan read 2018-05-04 11:03:40 UTC
Created attachment 1431268 [details]
File: syslog

Comment 14 morgan read 2018-05-04 11:03:42 UTC
Created attachment 1431269 [details]
File: ifcfg.log

Comment 15 morgan read 2018-05-04 11:03:44 UTC
Created attachment 1431270 [details]
File: packaging.log

Comment 16 morgan read 2018-05-04 11:04:13 UTC
Created attachment 1431271 [details]
File: anaconda-tb

Comment 17 morgan read 2018-05-04 11:08:55 UTC
Similar problem has been detected:

Leaving anaconda following previous bug report

addons:         com_redhat_kdump, com_redhat_docker
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-28 rd.live.check quiet
hashmarkername: anaconda
kernel:         4.16.3-301.fc28.x86_64
package:        anaconda-28.22.10
product:        Fedora
reason:         pyanaconda.payload.PayloadError: Payload error - DNF installation has ended up abruptly: ipa-common conflicts with (installed) freeipa-common-4.6.90.pre1-6.1.fc28.noarchTraceback (most recent call last):
release:        Cannot get release name.
version:        28

Comment 18 Martin Kolman 2018-05-04 11:17:33 UTC
While ideally this would be reported in a better way than with a traceback, it's definitely easier to report thanks to it. :)

Anaway, this is apparently a freeipa packaging issue, so reassigning.

Comment 19 Alexander Bokovoy 2018-05-04 11:43:07 UTC
Martin, this is really a bug in dnf.

FreeIPA has on purpose conflicts with ipa-* packages from RHEL:

Provides: %{alt_name}-server = %{version}
Conflicts: %{alt_name}-server
Obsoletes: %{alt_name}-server < %{version}

These combinations of Provides/Conflicts/Obsoletes handled well by rpm and basically allow to ensure %{alt_name}-server package is never installed if it isn't the same package as being installed.

It looks like DNF is not able to handle this situation under some circumstances. I'd rather have this fixed in DNF.

Comment 20 Martin Kolman 2018-05-04 11:56:45 UTC
(In reply to Alexander Bokovoy from comment #19)
> Martin, this is really a bug in dnf.
> 
> FreeIPA has on purpose conflicts with ipa-* packages from RHEL:
> 
> Provides: %{alt_name}-server = %{version}
> Conflicts: %{alt_name}-server
> Obsoletes: %{alt_name}-server < %{version}
> 
> These combinations of Provides/Conflicts/Obsoletes handled well by rpm and
> basically allow to ensure %{alt_name}-server package is never installed if
> it isn't the same package as being installed.
> 
> It looks like DNF is not able to handle this situation under some
> circumstances. I'd rather have this fixed in DNF.
OK, I'll CC some people from DNF so that they can investigate.

Comment 21 Jaroslav Mracek 2018-05-04 12:11:16 UTC
Martin, do you think it will be possible to get debugsolver data from anaconda. Or is there any reproducer in empty installroot. It really helps a lot.

Comment 22 Martin Kolman 2018-05-04 13:06:03 UTC
(In reply to Jaroslav Mracek from comment #21)
> Martin, do you think it will be possible to get debugsolver data from
> anaconda.
If I can reproduce the issue, I should be able to inject the necessary commands to generate the debugsolver output.

BTW, inspired by this, I've created bug 1574982, which is a RFE for easily enabling DNF debugsolver output in Anaconda.


> Or is there any reproducer in empty installroot. It really helps a
> lot.

Comment 23 Florence Blanc-Renaud 2018-06-04 08:16:07 UTC
Moving this issue to anaconda as it does not look like anything has changed recently on ipa packaging. See Comment #c19.

Comment 24 Joel Stienlet 2018-06-19 01:09:29 UTC
*** Bug 1592622 has been marked as a duplicate of this bug. ***

Comment 25 Leslie Satenstein 2018-06-19 13:44:51 UTC
Similar problem has been detected:

Installation of Fedora 28 using network install version

Message on screen, preparing transaction from installation source.  Transaction not specified

Some error  from log

blocking I/O error  [ Error 11 ]

Is this a Selinux error message??? 

addons:         com_redhat_docker, com_redhat_kdump
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=RFRemix-WS-28-x86_64 quiet
hashmarkername: anaconda
kernel:         4.16.3-301.fc28.x86_64
package:        anaconda-28.22.10
product:        Fedora
reason:         pyanaconda.payload.PayloadError: Payload error - DNF installation has ended up abruptly: texlive-collection-htmlxml <= 6:svn35743.0 is obsoleted by (installed) texlive-collection-formatsextra-7:svn44177-14.fc29.noarchTraceback (most recent call last):
release:        Fedora release 28 (Twenty Eight)
version:        28

Comment 26 Joel Stienlet 2018-06-20 00:18:42 UTC
In my case the problem came from the fact that:
- I created a separate /var partition
- the installation failed a first time (due to another unrelated error).
- when I tried to install the second time, I dit NOT format /var, which was thus not empty (files copied during the first failed install).
- when I formated /var on the 3rd attempt, the installation went without error.
note that this happened with the minimal install (I didn't ask to install ipa* packages)

Comment 27 Jiri Konecny 2018-06-20 06:59:03 UTC
Hello morgan,

Could you please verify the not-formatted /var partition or similar is also your problem?

Thanks

Comment 28 morgan read 2018-11-09 15:03:47 UTC
Yes, iirc, it was - looking back, this bug comment and following discussion seems to confirm that: https://bugzilla.redhat.com/show_bug.cgi?id=1575131#c25

Comment 29 Vendula Poncova 2018-11-12 14:43:37 UTC
Closing as a duplicate of 1575131 based in the comment 28.

*** This bug has been marked as a duplicate of bug 1575131 ***


Note You need to log in before you can comment on or make changes to this bug.