Bug 157496 - unable to commit characters in qt apps
unable to commit characters in qt apps
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qingyu Wang
: i18n
Depends On: 156168
Blocks: IIIMF FC4Update
  Show dependency treegraph
 
Reported: 2005-05-11 21:14 EDT by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 03:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-05-11 21:14:06 EDT
Description of problem:
At the moment, it is not possible to do any SC input in any qt apps irregardless
on KDE or GNOME desktop. Tried with both iiimxcf and iiimqcf as well. Both
client framework are able to display a list of candidates but after selecting
the candidates, it does not get committed to the apps

Version-Release number of selected component (if applicable):
iiimf-x-12.2-3
iiimf-qt-12.2-3
iiimf-le-chinput-0.3-19

How reproducible:
Always

Steps to Reproduce:
1.Log in as normal user into KDE at gdm with zh_CN locale
2.start kedit
3.enter hong
4.enter 1 to commit the first candidate
  
Actual results:
nothing gets committed and the preedit buffer is not cleared

Expected results:
candidate gets committed to the apps and preedit bugger = NULL

Additional info:
Putting into FC4Blocker as this has an impact on a large number of users.
Comment 1 Akira TAGOH 2005-06-15 00:40:23 EDT
I can see "hong" in the candidate window now when I press a backspace once and
type 'g' again. also enter 1, "hong" is committed into the applications.
Comment 2 Jens Petersen 2005-06-16 23:59:34 EDT
Yep, looks like a font problem.  Just displays like a black center dot for me.

Can you paste hong into kedit from another app?
When I do the same thing happens.
Comment 3 Caius Chance 2006-08-29 03:21:30 EDT
iiimf is not in fc5/fe5 package lists.

Note You need to log in before you can comment on or make changes to this bug.